aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/dts/rt3883_dlink_dir-645.dts
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2019-10-30 00:18:35 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-11-04 15:22:54 +0100
commit6ea5f7d44c8dccdf018af0aa9750903308aa95b7 (patch)
tree1b7c5343c49b51f1ac62fa93962bcf8f8fe5eb2c /target/linux/ramips/dts/rt3883_dlink_dir-645.dts
parent09fe0c847dd32a829fd3dcb21e284cc0c7a3e763 (diff)
downloadupstream-6ea5f7d44c8dccdf018af0aa9750903308aa95b7.tar.gz
upstream-6ea5f7d44c8dccdf018af0aa9750903308aa95b7.tar.bz2
upstream-6ea5f7d44c8dccdf018af0aa9750903308aa95b7.zip
ramips: fix MTK_SOC for RT3662 devices
rt3883.mk contains both RT3662 and RT3883 device profiles, but commit 6a104ac77206 set MTK_SOC to rt3883 for all devices. This patch fixes it, and renames dts files accordingly. And SoC compatible strings are also appended in the dts. Fixes: 6a104ac77206 ("ramips/rt288x,rt3883: Name DTS files based on scheme") Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/dts/rt3883_dlink_dir-645.dts')
-rw-r--r--target/linux/ramips/dts/rt3883_dlink_dir-645.dts152
1 files changed, 0 insertions, 152 deletions
diff --git a/target/linux/ramips/dts/rt3883_dlink_dir-645.dts b/target/linux/ramips/dts/rt3883_dlink_dir-645.dts
deleted file mode 100644
index 35d011ebba..0000000000
--- a/target/linux/ramips/dts/rt3883_dlink_dir-645.dts
+++ /dev/null
@@ -1,152 +0,0 @@
-/dts-v1/;
-
-#include "rt3883.dtsi"
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-/ {
- compatible = "dlink,dir-645", "ralink,rt3883-soc";
- model = "D-Link DIR-645";
-
- aliases {
- led-boot = &led_wps;
- led-failsafe = &led_wps;
- led-running = &led_wps;
- led-upgrade = &led_wps;
- };
-
- rtl8367b {
- compatible = "realtek,rtl8367b";
- gpio-sda = <&gpio0 1 GPIO_ACTIVE_HIGH>;
- gpio-sck = <&gpio0 2 GPIO_ACTIVE_HIGH>;
- realtek,extif1 = <1 0 1 1 1 1 1 1 2>;
- };
-
- keys {
- compatible = "gpio-keys-polled";
- poll-interval = <100>;
-
- reset {
- label = "reset";
- gpios = <&gpio0 9 GPIO_ACTIVE_HIGH>;
- linux,code = <KEY_RESTART>;
- };
-
- wps {
- label = "wps";
- gpios = <&gpio0 14 GPIO_ACTIVE_HIGH>;
- linux,code = <KEY_WPS_BUTTON>;
- };
- };
-
- leds {
- compatible = "gpio-leds";
-
- inet {
- label = "dir-645:green:inet";
- gpios = <&gpio0 0 GPIO_ACTIVE_LOW>;
- };
-
- led_wps: wps {
- label = "dir-645:green:wps";
- gpios = <&gpio1 2 GPIO_ACTIVE_HIGH>;
- };
- };
-
- gpio_export {
- compatible = "gpio-export";
- #size-cells = <0>;
-
- usb {
- gpio-export,name = "usb";
- gpio-export,output = <1>;
- gpios = <&gpio1 6 GPIO_ACTIVE_HIGH>;
- };
- };
-};
-
-&gpio1 {
- status = "okay";
-};
-
-&spi0 {
- status = "okay";
-
- m25p80@0 {
- compatible = "jedec,spi-nor";
- reg = <0>;
- spi-max-frequency = <25000000>;
-
- partitions {
- compatible = "fixed-partitions";
- #address-cells = <1>;
- #size-cells = <1>;
-
- partition@0 {
- label = "uboot";
- reg = <0x0 0x30000>;
- read-only;
- };
-
- partition@30000 {
- label = "uboot-env";
- reg = <0x30000 0x4000>;
- read-only;
- };
-
- factory: partition@34000 {
- label = "factory";
- reg = <0x34000 0x4000>;
- read-only;
- };
-
- partition@38000 {
- label = "nvram";
- reg = <0x38000 0x8000>;
- read-only;
- };
-
- partition@40000 {
- label = "devdata";
- reg = <0x40000 0x10000>;
- };
-
- partition@50000 {
- compatible = "seama";
- label = "firmware";
- reg = <0x50000 0x7b0000>;
- };
- };
- };
-};
-
-&pinctrl {
- state_default: pinctrl0 {
- gpio {
- ralink,group = "i2c", "jtag", "uartf";
- ralink,function = "gpio";
- };
- };
-};
-
-&ethernet {
- mtd-mac-address = <&factory 0x4>;
-
- port@0 {
- mediatek,fixed-link = <1000 1 1 0>;
- };
-};
-
-&wmac {
- ralink,5ghz = <0>;
- ralink,mtd-eeprom = <&factory 0>;
-};
-
-&ehci {
- status = "okay";
-};
-
-&ohci {
- status = "okay";
-};