aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/dts/rt3662_asus_rt-n56u.dts
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2019-10-30 00:18:35 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-11-04 15:22:54 +0100
commit6ea5f7d44c8dccdf018af0aa9750903308aa95b7 (patch)
tree1b7c5343c49b51f1ac62fa93962bcf8f8fe5eb2c /target/linux/ramips/dts/rt3662_asus_rt-n56u.dts
parent09fe0c847dd32a829fd3dcb21e284cc0c7a3e763 (diff)
downloadupstream-6ea5f7d44c8dccdf018af0aa9750903308aa95b7.tar.gz
upstream-6ea5f7d44c8dccdf018af0aa9750903308aa95b7.tar.bz2
upstream-6ea5f7d44c8dccdf018af0aa9750903308aa95b7.zip
ramips: fix MTK_SOC for RT3662 devices
rt3883.mk contains both RT3662 and RT3883 device profiles, but commit 6a104ac77206 set MTK_SOC to rt3883 for all devices. This patch fixes it, and renames dts files accordingly. And SoC compatible strings are also appended in the dts. Fixes: 6a104ac77206 ("ramips/rt288x,rt3883: Name DTS files based on scheme") Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/dts/rt3662_asus_rt-n56u.dts')
-rw-r--r--target/linux/ramips/dts/rt3662_asus_rt-n56u.dts151
1 files changed, 151 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/rt3662_asus_rt-n56u.dts b/target/linux/ramips/dts/rt3662_asus_rt-n56u.dts
new file mode 100644
index 0000000000..13f6cdd1dd
--- /dev/null
+++ b/target/linux/ramips/dts/rt3662_asus_rt-n56u.dts
@@ -0,0 +1,151 @@
+/dts-v1/;
+
+#include "rt3883.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "asus,rt-n56u", "ralink,rt3662-soc", "ralink,rt3883-soc";
+ model = "Asus RT-N56U";
+
+ aliases {
+ led-boot = &led_power;
+ led-failsafe = &led_power;
+ led-running = &led_power;
+ led-upgrade = &led_power;
+ };
+
+ nor-flash@1c000000 {
+ compatible = "cfi-flash";
+ reg = <0x1c000000 0x800000>;
+ bank-width = <2>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ reg = <0x0 0x0030000>;
+ label = "u-boot";
+ read-only;
+ };
+
+ partition@30000 {
+ reg = <0x00030000 0x00010000>;
+ label = "u-boot-env";
+ read-only;
+ };
+
+ factory: partition@40000 {
+ reg = <0x00040000 0x00010000>;
+ label = "factory";
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ reg = <0x00050000 0x007b0000>;
+ label = "firmware";
+ };
+ };
+ };
+
+ rtl8367 {
+ compatible = "realtek,rtl8367";
+ gpio-sda = <&gpio0 1 GPIO_ACTIVE_HIGH>;
+ gpio-sck = <&gpio0 2 GPIO_ACTIVE_HIGH>;
+ realtek,extif1 = <1 0 1 1 1 1 1 1 2>;
+ };
+
+ keys {
+ compatible = "gpio-keys-polled";
+ poll-interval = <100>;
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 13 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+
+ wps {
+ label = "wps";
+ gpios = <&gpio1 2 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power: power {
+ label = "rt-n56u:blue:power";
+ gpios = <&gpio0 0 GPIO_ACTIVE_LOW>;
+ };
+
+ lan {
+ label = "rt-n56u:blue:lan";
+ gpios = <&gpio0 19 GPIO_ACTIVE_LOW>;
+ };
+
+ wan {
+ label = "rt-n56u:blue:wan";
+ gpios = <&gpio1 3 GPIO_ACTIVE_LOW>;
+ };
+
+ usb {
+ label = "rt-n56u:blue:usb";
+ gpios = <&gpio1 0 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&gpio1 {
+ status = "okay";
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "spi", "i2c", "jtag", "uartf";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x4>;
+
+ port@0 {
+ mediatek,fixed-link = <1000 1 1 1>;
+ };
+};
+
+&pci {
+ status = "okay";
+};
+
+&pci1 {
+ status = "okay";
+
+ wifi@0,0 {
+ compatible = "pci1814,3091";
+ reg = <0x10000 0 0 0 0>;
+ ralink,mtd-eeprom = <&factory 0x8000>;
+ };
+};
+
+&wmac {
+ status = "okay";
+ ralink,2ghz = <0>;
+ ralink,mtd-eeprom = <&factory 0>;
+};
+
+&ehci {
+ status = "okay";
+};
+
+&ohci {
+ status = "okay";
+};