aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/dts/MLWG2.dts
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-01-28 10:37:51 +0000
committerJohn Crispin <blogic@openwrt.org>2015-01-28 10:37:51 +0000
commit3138fd5409a8611a784ba7579b2329f26c9c676a (patch)
tree4474fdb6f879f570edec5e983f26d23913dd2571 /target/linux/ramips/dts/MLWG2.dts
parent6513ba751cb1567457dfb6c00b88d19a0c586c0f (diff)
downloadupstream-3138fd5409a8611a784ba7579b2329f26c9c676a.tar.gz
upstream-3138fd5409a8611a784ba7579b2329f26c9c676a.tar.bz2
upstream-3138fd5409a8611a784ba7579b2329f26c9c676a.zip
BB : ramips : Backport for Kingston MLWG2
Backport r43990 to Barrier Breaker. http://wiki.openwrt.org/toh/kingston/mlwg2 Signed-off-by: L. D. Pinney <ldpinney@gmail.com> target/linux/ramips/base-files/etc/diag.sh | 3 +++ target/linux/ramips/base-files/etc/uci-defaults/01_leds | 4 +++ target/linux/ramips/base-files/etc/uci-defaults/02_network | 4 +++ target/linux/ramips/base-files/lib/ramips.sh | 3 +++ target/linux/ramips/base-files/lib/upgrade/platform.sh | 1 + target/linux/ramips/dts/MLWG2.dts | 118 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ target/linux/ramips/image/Makefile | 2 ++ 7 files changed, 135 insertions(+) git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@44160 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/dts/MLWG2.dts')
-rw-r--r--target/linux/ramips/dts/MLWG2.dts118
1 files changed, 118 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/MLWG2.dts b/target/linux/ramips/dts/MLWG2.dts
new file mode 100644
index 0000000000..a2b0033150
--- /dev/null
+++ b/target/linux/ramips/dts/MLWG2.dts
@@ -0,0 +1,118 @@
+/dts-v1/;
+
+/include/ "mt7620n.dtsi"
+
+/ {
+ compatible = "mlwg2", "ralink,mt7620n-soc";
+ model = "Kingston MLWG2";
+
+ palmbus@10000000 {
+ gpio0: gpio@600 {
+ status = "okay";
+ };
+
+ gpio2: gpio@660 {
+ status = "okay";
+ };
+
+ gpio3: gpio@688 {
+ status = "okay";
+ };
+
+ spi@b00 {
+ status = "okay";
+
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "mx25l12805d";
+ reg = <0 0>;
+ linux,modalias = "m25p80";
+ spi-max-frequency = <10000000>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0xf60000>;
+ };
+
+ partition@fb0000 {
+ label = "user-config";
+ reg = <0xfb0000 0x50000>;
+ };
+ };
+ };
+ };
+
+ ehci@101c0000 {
+ status = "okay";
+ };
+
+ ohci@101c1000 {
+ status = "okay";
+ };
+
+ ethernet@10100000 {
+ mtd-mac-address = <&factory 0x4>;
+ ralink,port-map = "wllll";
+ };
+
+ wmac@10180000 {
+ ralink,mtd-eeprom = <&factory 0>;
+ };
+
+ pinctrl {
+ state_default: pinctrl0 {
+ default {
+ ralink,group = "i2c", "ephy", "wled";
+ ralink,function = "gpio";
+ };
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+ system {
+ label = "kingston:blue:system";
+ gpios = <&gpio2 3 1>;
+ };
+ wifi {
+ label = "kingston:blue:wifi";
+ gpios = <&gpio3 0 1>;
+ };
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+ reset {
+ label = "reset";
+ gpios = <&gpio0 1 1>;
+ linux,code = <0x198>;
+ };
+ system {
+ label = "system";
+ gpios = <&gpio0 2 1>;
+ linux,code = <0x211>;
+ };
+ };
+};