aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2017-05-04 14:07:47 +0200
committerDaniel Golle <daniel@makrotopia.org>2017-05-04 14:13:23 +0200
commitd17cb4a68a4544dca690629ee9a2483da29fa42a (patch)
treebfeef84ba77dc4ce88edeea770c89368c0383b27 /target/linux/ramips/Makefile
parentbe40d0a144937a788fa8902e3335a25586acaa95 (diff)
downloadupstream-d17cb4a68a4544dca690629ee9a2483da29fa42a.tar.gz
upstream-d17cb4a68a4544dca690629ee9a2483da29fa42a.tar.bz2
upstream-d17cb4a68a4544dca690629ee9a2483da29fa42a.zip
ramips: purge default packages on MT7621
In order to have a smaller initramfs image remove all packages not needed on all devices and add them explicitely for those actually needing them. Also remove wpad-mini from ramips default package set and add it to all sub-targets except for MT7621. While at it reorder packages alphabetically and replace kmod-mt76 with kmod-mt7603 and/or kmod-mt76x2 depending on the chip actually used on a specific board. Hopefully fixes FS#758 Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/ramips/Makefile')
-rw-r--r--target/linux/ramips/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/Makefile b/target/linux/ramips/Makefile
index 25859024c1..1de220e1a3 100644
--- a/target/linux/ramips/Makefile
+++ b/target/linux/ramips/Makefile
@@ -21,6 +21,6 @@ endef
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += \
- kmod-leds-gpio kmod-gpio-button-hotplug wpad-mini swconfig
+ kmod-leds-gpio kmod-gpio-button-hotplug swconfig
$(eval $(call BuildTarget))