aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/Makefile
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-08-30 19:15:51 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-08-30 19:15:51 +0000
commit051c44e0c5886d3e9a0f994221bfc84765cf3cfc (patch)
tree7c21aa22ba5a6b629f32e40943c43619f66d7ea6 /target/linux/ramips/Makefile
parent91fe3635620bc4de40982c23cbc67307a93bf354 (diff)
downloadupstream-051c44e0c5886d3e9a0f994221bfc84765cf3cfc.tar.gz
upstream-051c44e0c5886d3e9a0f994221bfc84765cf3cfc.tar.bz2
upstream-051c44e0c5886d3e9a0f994221bfc84765cf3cfc.zip
initial support for RT288x/RT305x
SVN-Revision: 17439
Diffstat (limited to 'target/linux/ramips/Makefile')
-rw-r--r--target/linux/ramips/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ramips/Makefile b/target/linux/ramips/Makefile
new file mode 100644
index 0000000000..ceca5aeca5
--- /dev/null
+++ b/target/linux/ramips/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2008-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=ramips
+BOARDNAME:=Ralink RT288x/RT305x
+SUBTARGETS:=rt288x rt305x
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
+
+LINUX_VERSION:=2.6.30.5
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build firmware images for Ralink RT288x/RT305x based boards.
+endef
+
+$(eval $(call BuildTarget))