aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/qoriq
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2022-04-26 18:18:20 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2022-06-29 01:42:15 +0300
commit88101fa23950b1d40909d2d334966f02c53837f3 (patch)
tree912426e5393732b3c088a1126480c4213e4707db /target/linux/qoriq
parent2b8021d6141c7edd813138e128140ca7b002be4f (diff)
downloadupstream-88101fa23950b1d40909d2d334966f02c53837f3.tar.gz
upstream-88101fa23950b1d40909d2d334966f02c53837f3.tar.bz2
upstream-88101fa23950b1d40909d2d334966f02c53837f3.zip
qoriq: use KERNEL_SUFFIX in Build/sdcard-img
Use the KERNEL_SUFFIX variable in Build/sdcard-img, rather than using hardcoded "-kernel.bin", to allow overriding KERNEL_SUFFIX for a device. Fixes: 080a769b4da8 ("qoriq: new target") Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> (cherry picked from commit 86948716dbc1c220d4be504cfe5433bfd9e1d630)
Diffstat (limited to 'target/linux/qoriq')
-rw-r--r--target/linux/qoriq/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/qoriq/image/Makefile b/target/linux/qoriq/image/Makefile
index a3c8dd38c2..ec46e4d543 100644
--- a/target/linux/qoriq/image/Makefile
+++ b/target/linux/qoriq/image/Makefile
@@ -8,7 +8,7 @@ SQUASHFSCOMP := xz $(LZMA_XZ_OPTIONS)
define Build/sdcard-img
rm -fR $@.boot
mkdir -p $@.boot
- $(CP) $(KDIR)/$(DEVICE_NAME)-kernel.bin $@.boot
+ $(CP) $(KDIR)/$(DEVICE_NAME)$(KERNEL_SUFFIX) $@.boot
$(if $(DEVICE_DTS),\
$(foreach dtb,$(DEVICE_DTS),$(CP) $(KDIR)/image-$(dtb).dtb $@.boot), \
$(CP) $(KDIR)/image-/*.dtb $@.boot)