aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/pxcab/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-07-16 10:19:13 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-07-16 10:19:13 +0000
commitf49a6c5859bcfcbe59fb8c125d6fdcbbcb3360ed (patch)
treeda320bef34fb95f56667a13fd6a6a7c648edc338 /target/linux/pxcab/Makefile
parent515df8d0dd2d48d316681f7aad99694e783b64c8 (diff)
downloadupstream-f49a6c5859bcfcbe59fb8c125d6fdcbbcb3360ed.tar.gz
upstream-f49a6c5859bcfcbe59fb8c125d6fdcbbcb3360ed.tar.bz2
upstream-f49a6c5859bcfcbe59fb8c125d6fdcbbcb3360ed.zip
This patch adds a target for the IBM PowerXCell Accelerator Board.
(aka mvXCell-8i from MatrixVision or GigaAccel 180 from Fixstars) http://us.fixstars.com/products/gigaaccel/ This build will create zImage suitable for TFTP boot image. * v2 - add axonram device driver - switch to 2.6.30.1 Signed-off-by: Akinobu Mita <mita@fixstars.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16860 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/pxcab/Makefile')
-rw-r--r--target/linux/pxcab/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/pxcab/Makefile b/target/linux/pxcab/Makefile
new file mode 100644
index 0000000000..5957d65fac
--- /dev/null
+++ b/target/linux/pxcab/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=pxcab
+BOARDNAME:=PowerXCell Accelerator Board
+FEATURES:=fpu ramdisk
+
+LINUX_VERSION:=2.6.30.1
+
+KERNEL_CC:=
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build zImage for the IBM PowerXCell Accelerator Board
+ (aka mvXCell-8i from MatrixVision or GigaAccel 180 from Fixstars)
+endef
+
+KERNELNAME:="zImage"
+
+DEFAULT_PACKAGES += kmod-tg3
+
+$(eval $(call BuildTarget))