aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/pxa/image
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-12 10:08:18 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-12 10:08:18 +0000
commita68d8a660a60aa0b0f4e0068ede44e5e07007b0e (patch)
tree0b0d5f52844fdcbbcdf10ae7e80cbb269e6106eb /target/linux/pxa/image
parent2172d7dbbfe453ea81ebf0b4e62d8101a7d5d1f0 (diff)
downloadupstream-a68d8a660a60aa0b0f4e0068ede44e5e07007b0e.tar.gz
upstream-a68d8a660a60aa0b0f4e0068ede44e5e07007b0e.tar.bz2
upstream-a68d8a660a60aa0b0f4e0068ede44e5e07007b0e.zip
pxa: moved to targets feed
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48217
Diffstat (limited to 'target/linux/pxa/image')
-rw-r--r--target/linux/pxa/image/Makefile43
1 files changed, 0 insertions, 43 deletions
diff --git a/target/linux/pxa/image/Makefile b/target/linux/pxa/image/Makefile
deleted file mode 100644
index b8723363da..0000000000
--- a/target/linux/pxa/image/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-#
-# Copyright (C) 2008-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-define Image/BuildKernel
- cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
-endef
-
-# Build a fake flash image for usage in Qemu
-define Image/Build/Gumstix
- dd if=/dev/zero bs=128k count=256 of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
- dd if=$(BIN_DIR)/openwrt-pxa-gumstix-u-boot.bin conv=notrunc bs=128k \
- of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
- dd if=$(KDIR)/root.$(1) conv=notrunc bs=128k seek=2 \
- of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
- dd if=$(KDIR)/uImage conv=notrunc bs=128k seek=248 \
- of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
-endef
-
-define Image/Build
- $(call Image/Build/$(1),$(1))
- $(call Image/Build/$(PROFILE),$(1))
-endef
-
-define Image/Build/jffs2-64k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=64k conv=sync
-endef
-
-define Image/Build/jffs2-128k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=128k conv=sync
-endef
-
-define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img bs=128k conv=sync
-endef
-
-$(eval $(call BuildImage))