aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/pxa/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-04-27 16:56:19 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-04-27 16:56:19 +0000
commitac347b46b0f895afc1b473a2ed5574d82863f2da (patch)
treedbcd5d214918a932007299fa02556ce313a194be /target/linux/pxa/image
parentb0cbd7726dbdf81979887c2e339bdb6bdb061b7b (diff)
downloadupstream-ac347b46b0f895afc1b473a2ed5574d82863f2da.tar.gz
upstream-ac347b46b0f895afc1b473a2ed5574d82863f2da.tar.bz2
upstream-ac347b46b0f895afc1b473a2ed5574d82863f2da.zip
incomplete Gumstix support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10955 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/pxa/image')
-rw-r--r--target/linux/pxa/image/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/target/linux/pxa/image/Makefile b/target/linux/pxa/image/Makefile
new file mode 100644
index 0000000000..64330b0260
--- /dev/null
+++ b/target/linux/pxa/image/Makefile
@@ -0,0 +1,35 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+endef
+
+define Image/BuildKernel
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-64k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=65536 conv=sync
+endef
+
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+endef
+
+$(eval $(call BuildImage))