aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ps3/petitboot/profiles
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2009-04-16 10:40:15 +0000
committerHamish Guthrie <hcg@openwrt.org>2009-04-16 10:40:15 +0000
commit9cb51ecd82338be594eeec7ff8e050efd2e95fb0 (patch)
tree530260591c27d09eefa7b4c43f72bafe40c20840 /target/linux/ps3/petitboot/profiles
parentf25cd709d414bf2d4630f7a32fb43a556e9d8dd6 (diff)
downloadupstream-9cb51ecd82338be594eeec7ff8e050efd2e95fb0.tar.gz
upstream-9cb51ecd82338be594eeec7ff8e050efd2e95fb0.tar.bz2
upstream-9cb51ecd82338be594eeec7ff8e050efd2e95fb0.zip
[ps3]: Update default configuration to use profiles
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15229 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ps3/petitboot/profiles')
-rw-r--r--target/linux/ps3/petitboot/profiles/000-Default.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ps3/petitboot/profiles/000-Default.mk b/target/linux/ps3/petitboot/profiles/000-Default.mk
new file mode 100644
index 0000000000..5c433e1339
--- /dev/null
+++ b/target/linux/ps3/petitboot/profiles/000-Default.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+ NAME:=Default PS3 Petitboot profile
+ PACKAGES:=-dnsmasq -iptables -ppp -ppp-mod-pppoe -kmod-ipt-nathelper \
+ -firewall \
+ kexec-tools petitboot
+endef
+
+define Profile/Default/Description
+ Default PS3 Petitboot profile
+endef
+$(eval $(call Profile,Default))
+