aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ppc44x/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-02-03 14:54:01 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-02-03 14:54:01 +0000
commit9fb754391094e68c551dcd35211e5bdd52d56324 (patch)
tree1fa907567ca4d85f71bc7d74105e1a8178bd59a2 /target/linux/ppc44x/image
parent4a0e29e5ce6a9080a1277c4d3c7e43f19bd7ffc0 (diff)
downloadupstream-9fb754391094e68c551dcd35211e5bdd52d56324.tar.gz
upstream-9fb754391094e68c551dcd35211e5bdd52d56324.tar.bz2
upstream-9fb754391094e68c551dcd35211e5bdd52d56324.zip
convert ppc44x to arch/powerpc, use squashfs images by default
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10372 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ppc44x/image')
-rw-r--r--target/linux/ppc44x/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ppc44x/image/Makefile b/target/linux/ppc44x/image/Makefile
index bd284eb975..5c1d023cb0 100644
--- a/target/linux/ppc44x/image/Makefile
+++ b/target/linux/ppc44x/image/Makefile
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/image.mk
JFFS2_BLOCKSIZE=256k
define Image/Prepare
- cp $(LINUX_DIR)/arch/ppc/boot/images/uImage $(KDIR)/uImage
+ cp $(LINUX_DIR)/arch/powerpc/boot/cuImage.taishan $(KDIR)/uImage
endef
define Image/BuildKernel
@@ -23,7 +23,7 @@ endef
define Image/Build/jffs2-256k
( \
- dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=4096k conv=sync; \
+ dd if=$(KDIR)/uImage bs=2048k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-jffs2.img
endef
@@ -31,7 +31,7 @@ endef
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
( \
- dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=4096k conv=sync; \
+ dd if=$(KDIR)/uImage bs=2048k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
endef