aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ppc44x/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-01-27 23:11:21 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-01-27 23:11:21 +0000
commit18ce9e8974f2a39c5c3b42c5e2eda97533e1ecdc (patch)
tree446e12dc753b7f9a254f9f497d6d8c2c877b22c7 /target/linux/ppc44x/Makefile
parent2d2ae16453082c8e710e0228d64ce4a0d2748f6f (diff)
downloadupstream-18ce9e8974f2a39c5c3b42c5e2eda97533e1ecdc.tar.gz
upstream-18ce9e8974f2a39c5c3b42c5e2eda97533e1ecdc.tar.bz2
upstream-18ce9e8974f2a39c5c3b42c5e2eda97533e1ecdc.zip
* Rename the AMCC target to PPC44x
* Upgrade PPC44x to 2.6.23 git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10290 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ppc44x/Makefile')
-rw-r--r--target/linux/ppc44x/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ppc44x/Makefile b/target/linux/ppc44x/Makefile
new file mode 100644
index 0000000000..ed43ccaec7
--- /dev/null
+++ b/target/linux/ppc44x/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=ppc44x
+BOARDNAME:=AMCC Taishan
+FEATURES:=jffs2
+
+LINUX_VERSION:=2.6.23.14
+LINUX_KARCH:=ppc
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build firmware images for the AMCC Taishan evaluation board
+endef
+
+$(eval $(call BuildTarget))