aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-04-12 12:21:15 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-04-12 12:21:15 +0000
commitbc4cd8c850516ab3adfd5b4748d8b3430718fbcf (patch)
treeb70b086650c1f22787de5d8cd6e26fd1cbf2f0f6 /target/linux/ppc40x
parentbd0c2617f15f624a3e22f2e6c75fb3c812a15ae1 (diff)
downloadupstream-bc4cd8c850516ab3adfd5b4748d8b3430718fbcf.tar.gz
upstream-bc4cd8c850516ab3adfd5b4748d8b3430718fbcf.tar.bz2
upstream-bc4cd8c850516ab3adfd5b4748d8b3430718fbcf.zip
ppc40x: increase kernel partition size on OpenRB/Magicbox
Cc: backfire@openwrt.org SVN-Revision: 20820
Diffstat (limited to 'target/linux/ppc40x')
-rw-r--r--target/linux/ppc40x/image/Makefile8
-rw-r--r--target/linux/ppc40x/patches/004-magicbox.patch8
-rw-r--r--target/linux/ppc40x/patches/005-openrb.patch4
3 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/ppc40x/image/Makefile b/target/linux/ppc40x/image/Makefile
index 4544aff4ff..c0ecd7f7d9 100644
--- a/target/linux/ppc40x/image/Makefile
+++ b/target/linux/ppc40x/image/Makefile
@@ -36,11 +36,11 @@ endef
define Image/Build/jffs2-64k
( \
- dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1152k conv=sync; \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1280k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-magicbox-jffs2.img
( \
- dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1152k conv=sync; \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1280k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-jffs2.img
endef
@@ -53,11 +53,11 @@ define Image/Build/squashfs
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-kilauea-$(1).img
( \
- dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1152k conv=sync; \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicbox bs=1280k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-magicbox-$(1).img
( \
- dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1152k conv=sync; \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb bs=1280k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-$(1).img
endef
diff --git a/target/linux/ppc40x/patches/004-magicbox.patch b/target/linux/ppc40x/patches/004-magicbox.patch
index 95736a1e0c..ff18b49fa0 100644
--- a/target/linux/ppc40x/patches/004-magicbox.patch
+++ b/target/linux/ppc40x/patches/004-magicbox.patch
@@ -318,15 +318,15 @@
+ #size-cells = <1>;
+ partition@0 {
+ label = "linux";
-+ reg = <0x0 0x120000>;
++ reg = <0x0 0x140000>;
+ };
+ partition@120000 {
+ label = "rootfs";
-+ reg = <0x120000 0x2a0000>;
++ reg = <0x140000 0x680000>;
+ };
-+ partition@3c0000 {
++ partition@7c0000 {
+ label = "u-boot";
-+ reg = <0x3c0000 0x30000>;
++ reg = <0x7c0000 0x30000>;
+ read-only;
+ };
+ };
diff --git a/target/linux/ppc40x/patches/005-openrb.patch b/target/linux/ppc40x/patches/005-openrb.patch
index b6dff6eba5..46ea6f6e06 100644
--- a/target/linux/ppc40x/patches/005-openrb.patch
+++ b/target/linux/ppc40x/patches/005-openrb.patch
@@ -294,11 +294,11 @@
+ #size-cells = <1>;
+ partition@0 {
+ label = "linux";
-+ reg = <0x0 0x120000>;
++ reg = <0x0 0x140000>;
+ };
+ partition@120000 {
+ label = "rootfs";
-+ reg = <0x120000 0x6a0000>;
++ reg = <0x140000 0x680000>;
+ };
+ partition@7c0000 {
+ label = "u-boot";