aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-07-09 20:48:56 +0200
committerMathias Kresin <dev@kresin.me>2018-07-12 18:15:32 +0200
commitcf7154db07c0b8746be290c9e11dcab3c91d237e (patch)
tree409a783abc61a0d6622e8f76d92bd9e97705d01c /target/linux/ppc40x
parent621fa91a8295b50dfdfac22290200064afaeec4e (diff)
downloadupstream-cf7154db07c0b8746be290c9e11dcab3c91d237e.tar.gz
upstream-cf7154db07c0b8746be290c9e11dcab3c91d237e.tar.bz2
upstream-cf7154db07c0b8746be290c9e11dcab3c91d237e.zip
kernel: only optimized for size if small_flash
Add a new config option to allow to select the default compile optimization level for the kernel. Select the optimization for size by default if the small_flash feature is set. Otherwise "Optimize for performance" is set. Add the small_flash feature flag to all (sub)targets which had the optimization for size in their default kernel config. Remove CC_OPTIMIZE_FOR_* symbols from all kernel configs to apply the new setting. Exceptions to the above are: - lantiq, where the optimization for size is only required for the xway_legacy subtarget but was set for the whole target - mediatek, ramips/mt7620 & ramips/mt76x8 where boards should have plenty of space and an optimization for size doesn't make much sense - rb532, which has 128MByte flash Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ppc40x')
-rw-r--r--target/linux/ppc40x/Makefile2
-rw-r--r--target/linux/ppc40x/config-3.181
2 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
index 3529bb3db5..ebe09988a8 100644
--- a/target/linux/ppc40x/Makefile
+++ b/target/linux/ppc40x/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=powerpc
BOARD:=ppc40x
BOARDNAME:=AMCC/IBM PPC40x
-FEATURES:=squashfs broken
+FEATURES:=squashfs small_flash broken
CPU_TYPE:=405
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
diff --git a/target/linux/ppc40x/config-3.18 b/target/linux/ppc40x/config-3.18
index 85bbe0cb9b..fc53dde8c1 100644
--- a/target/linux/ppc40x/config-3.18
+++ b/target/linux/ppc40x/config-3.18
@@ -27,7 +27,6 @@ CONFIG_ARCH_WANT_OPTIONAL_GPIOLIB=y
CONFIG_AUDIT_ARCH=y
CONFIG_BOOKE_WDT=y
CONFIG_BOUNCE=y
-CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_CLONE_BACKWARDS=y
CONFIG_CMDLINE="console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd"
CONFIG_CMDLINE_BOOL=y