aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/pistachio/image/Makefile
diff options
context:
space:
mode:
authorNick Hainke <vincent@systemli.org>2022-09-28 14:14:13 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2023-01-24 00:30:47 +0100
commit496d32cb7827e12c0432d5310dc52220d7aed390 (patch)
tree8eee98d1032a7f8f49b30b2a8498097aa2190dda /target/linux/pistachio/image/Makefile
parent94059ce86412b0ed5589d79661bceb1d2ea443af (diff)
downloadupstream-496d32cb7827e12c0432d5310dc52220d7aed390.tar.gz
upstream-496d32cb7827e12c0432d5310dc52220d7aed390.tar.bz2
upstream-496d32cb7827e12c0432d5310dc52220d7aed390.zip
pistachio: add 5.15 testing kernel
Manually refreshed: - 903-MIPS-DTS-img-marduk-Add-NXP-SC16IS752IPW.patch - 905-MIPS-DTS-img-marduk-Add-led-aliases.patch (led node was renamed to led-1) Automatically refreshed: - 109-MIPS-DTS-img-marduk-switch-mmc-to-1-bit-mode.patch - 401-mtd-nor-support-mtd-name-from-device-tree.patch - 901-MIPS-DTS-img-marduk-Add-SPI-NAND-flash.patch - 902-MIPS-DTS-img-marduk-Add-Cascoda-CA8210-6LoWPAN.patch - 904-MIPS-DTS-img-marduk-Add-partition-name.patch Enable testing kernel. Co-Developed-by: Hauke Mehrtens <hauke@hauke-m.de> Tested-by: Hauke Mehrtens <hauke@hauke-m.de> Signed-off-by: Nick Hainke <vincent@systemli.org>
Diffstat (limited to 'target/linux/pistachio/image/Makefile')
-rw-r--r--target/linux/pistachio/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/pistachio/image/Makefile b/target/linux/pistachio/image/Makefile
index 2e15005ac2..9c0e9da91f 100644
--- a/target/linux/pistachio/image/Makefile
+++ b/target/linux/pistachio/image/Makefile
@@ -5,7 +5,11 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-KERNEL_LOADADDR := 0x80400000
+ifdef CONFIG_LINUX_5_10
+ KERNEL_LOADADDR := 0x80400000
+else
+ KERNEL_LOADADDR := 0x80100000
+endif
define Device/Default
PROFILES := Default