aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/package
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-01-17 15:45:36 +0000
committerNicolas Thill <nico@openwrt.org>2006-01-17 15:45:36 +0000
commita97b1c73cd9e29857b72f97ce32c7a8ba422afa9 (patch)
tree6854221622cd3cf05b47e2aa42a8c0d7b46e8db3 /target/linux/package
parent968f6c030cd71a5a6239c8c4e6eeaaa15d88bac9 (diff)
downloadupstream-a97b1c73cd9e29857b72f97ce32c7a8ba422afa9.tar.gz
upstream-a97b1c73cd9e29857b72f97ce32c7a8ba422afa9.tar.bz2
upstream-a97b1c73cd9e29857b72f97ce32c7a8ba422afa9.zip
add a patch to export various kernel symbols in lib/string.c (like in 2.6),
fix shfs build on 2.4 (hopefully, but no real tests yet) git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3004 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/package')
-rw-r--r--target/linux/package/shfs/patches/101-kmod_build.patch9
1 files changed, 2 insertions, 7 deletions
diff --git a/target/linux/package/shfs/patches/101-kmod_build.patch b/target/linux/package/shfs/patches/101-kmod_build.patch
index 635900472d..11701033f5 100644
--- a/target/linux/package/shfs/patches/101-kmod_build.patch
+++ b/target/linux/package/shfs/patches/101-kmod_build.patch
@@ -1,6 +1,6 @@
--- shfs-0.35-orig/shfs/Linux-2.4/Makefile 2004-06-01 15:16:19.000000000 +0200
+++ shfs-0.35-2/shfs/Linux-2.4/Makefile 2005-04-09 02:34:35.000000000 +0200
-@@ -1,3 +1,17 @@
+@@ -1,3 +1,13 @@
+#
+# the original Makefile was trashed and replaced by this one
+# The main reason is that loadable modules should be built with
@@ -10,15 +10,11 @@
+# make -C $(KERNEL_DIR) SUBDIRS="$(shell pwd)" modules
+# make -C $(KERNEL_DIR) SUBDIRS="$(shell pwd)" modules_install
+#
-+#
-+# $(TOPDIR)/lib/string.o is needed at link time because the memchr function
-+# is not exported on mips (insmod: unresolved symbol memchr)
-+#
+
ifndef KERNEL
KERNEL=$(shell uname -r)
endif
-@@ -10,67 +24,30 @@
+@@ -10,67 +24,29 @@
KERNEL_SOURCES=${MODULESDIR}/build
endif
@@ -99,5 +95,4 @@
+ rm -f core *.o *.a *.s
+
+shfs.o: $(shfs-objs)
-+ $(LD) -r -o $@ $(shfs-objs) $(TOPDIR)/lib/string.o
+