aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-12-25 21:57:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-12-25 21:57:14 +0000
commita846d900c81363ae637aadf6e876bbdb23365840 (patch)
tree686774bec893e7347c78f8c3aa837c0ac5f2ae2e /target/linux/package
parentf351d6cd520ea8f37c1bc65c3a83405b68fe30f7 (diff)
downloadupstream-a846d900c81363ae637aadf6e876bbdb23365840.tar.gz
upstream-a846d900c81363ae637aadf6e876bbdb23365840.tar.bz2
upstream-a846d900c81363ae637aadf6e876bbdb23365840.zip
fix kernel version detection in switch driver
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2782 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/package')
-rw-r--r--target/linux/package/switch/src/Makefile3
-rw-r--r--target/linux/package/switch/src/switch-core.h9
2 files changed, 11 insertions, 1 deletions
diff --git a/target/linux/package/switch/src/Makefile b/target/linux/package/switch/src/Makefile
index e4b2b7f38b..4c5f911ea2 100644
--- a/target/linux/package/switch/src/Makefile
+++ b/target/linux/package/switch/src/Makefile
@@ -11,8 +11,9 @@
#
obj-m := switch-core.o switch-adm.o switch-robo.o
-export-objs := switch-core.o
ifeq ($(MAKING_MODULES),1)
+export-objs := switch-core.o
+
-include $(TOPDIR)/Rules.make
endif
diff --git a/target/linux/package/switch/src/switch-core.h b/target/linux/package/switch/src/switch-core.h
index c878d47868..9927e85192 100644
--- a/target/linux/package/switch/src/switch-core.h
+++ b/target/linux/package/switch/src/switch-core.h
@@ -1,6 +1,7 @@
#ifndef __SWITCH_CORE_H
#define __SWITCH_CORE_H
+#include <linux/version.h>
#include <linux/list.h>
#define SWITCH_MAX_BUFSZ 4096
@@ -8,6 +9,14 @@
#define SWITCH_MEDIA_100 2
#define SWITCH_MEDIA_FD 4
+#ifndef KERNEL_VERSION
+#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))
+#endif
+
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,5,0)
+#define LINUX_2_4
+#endif
+
typedef int (*switch_handler)(char *buf, int nr);
typedef struct {