aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/package
diff options
context:
space:
mode:
authorWaldemar Brodkorb <wbx@openwrt.org>2006-01-09 17:16:22 +0000
committerWaldemar Brodkorb <wbx@openwrt.org>2006-01-09 17:16:22 +0000
commit216f14a4125d7c4919f3fca50ff17e00ee9dd13d (patch)
tree04aa590cbd44ea25c57de38f2739a41532be2af7 /target/linux/package
parentc021f138d6ec2f66d081cb1960a529ebc6b99cd9 (diff)
downloadupstream-216f14a4125d7c4919f3fca50ff17e00ee9dd13d.tar.gz
upstream-216f14a4125d7c4919f3fca50ff17e00ee9dd13d.tar.bz2
upstream-216f14a4125d7c4919f3fca50ff17e00ee9dd13d.zip
x86-2.6 compile fixes for snapshot build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2867 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/package')
-rw-r--r--target/linux/package/Makefile2
-rw-r--r--target/linux/package/alsa/Makefile2
2 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/package/Makefile b/target/linux/package/Makefile
index 5fc604d5a9..3d28ca77e3 100644
--- a/target/linux/package/Makefile
+++ b/target/linux/package/Makefile
@@ -2,8 +2,10 @@
include $(TOPDIR)/rules.mk
ifneq ($(BOARD),ar7)
+ifneq ($(BOARD)-$(KERNEL),x86-2.6)
package-$(BR2_PACKAGE_KMOD_ALSA) += alsa
endif
+endif
package-$(BR2_PACKAGE_KMOD_FUSE) += fuse
package-$(BR2_PACKAGE_KMOD_HOSTAP) += hostap
package-$(BR2_PACKAGE_KMOD_BCM43XX_DSCAPE) += bcm43xx-dscape
diff --git a/target/linux/package/alsa/Makefile b/target/linux/package/alsa/Makefile
index eea05a0748..02baa44b34 100644
--- a/target/linux/package/alsa/Makefile
+++ b/target/linux/package/alsa/Makefile
@@ -21,7 +21,7 @@ endif
include $(TOPDIR)/package/rules.mk
ifeq ($(LINUX_KARCH),i386)
-KERNEL_C_INCS:=
+KERNEL_C_INCS:= -I$(KERNEL_DIR)/include/asm-i386/mach-generic
KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
endif
ifeq ($(LINUX_KARCH),mips)