aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/profiles/100-Generic.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-20 14:41:13 +0000
committerJohn Crispin <john@openwrt.org>2016-03-20 14:41:13 +0000
commit3cea0747d6ffd0d791f9c32e4d1c09f58aed0fac (patch)
tree18dbe92a05ac307ee0aab849a5d494a4cc8616bf /target/linux/oxnas/profiles/100-Generic.mk
parent4fe3fda78af4c9ebad06d8efc342ce58237cc44a (diff)
downloadupstream-3cea0747d6ffd0d791f9c32e4d1c09f58aed0fac.tar.gz
upstream-3cea0747d6ffd0d791f9c32e4d1c09f58aed0fac.tar.bz2
upstream-3cea0747d6ffd0d791f9c32e4d1c09f58aed0fac.zip
oxnas: add Default profile and reorganize device profiles
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 49040
Diffstat (limited to 'target/linux/oxnas/profiles/100-Generic.mk')
-rw-r--r--target/linux/oxnas/profiles/100-Generic.mk48
1 files changed, 0 insertions, 48 deletions
diff --git a/target/linux/oxnas/profiles/100-Generic.mk b/target/linux/oxnas/profiles/100-Generic.mk
deleted file mode 100644
index 5304839754..0000000000
--- a/target/linux/oxnas/profiles/100-Generic.mk
+++ /dev/null
@@ -1,48 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/POGOPLUG_PRO
- NAME:=PogoPlug Pro
-endef
-
-define Profile/POGOPLUG_PRO/Description
- Profile with built-in ox820 PogoPlug Pro device-tree
- (board with miniPCIe slot)
-endef
-
-define Profile/POGOPLUG_V3
- NAME:=PogoPlug V3
-endef
-
-define Profile/POGOPLUG_V3/Description
- Profile with built-in ox820 PogoPlug V3 device-tree
- (board without miniPCIe slot)
-endef
-
-define Profile/STG212
- NAME:=MitraStar STG-212
-endef
-
-define Profile/STG212/Description
- Profile with built-in ox820 STG-212 device-tree
-endef
-
-define Profile/KD20
- NAME:=Shuttle KD20
- PACKAGES:= \
- kmod-usb3 kmod-usb-storage kmod-i2c-gpio kmod-rtc-pcf8563 \
- kmod-gpio-beeper kmod-hwmon-core kmod-hwmon-gpiofan
-endef
-
-define Profile/KD20/Description
- Profile with built-in ox820 KD20 device-tree
-endef
-
-$(eval $(call Profile,POGOPLUG_PRO))
-$(eval $(call Profile,POGOPLUG_V3))
-$(eval $(call Profile,STG212))
-$(eval $(call Profile,KD20))