aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.4/300-introduce-oxnas-platform.patch
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-05-31 17:28:38 +0200
committerDaniel Golle <daniel@makrotopia.org>2018-06-18 18:44:14 +0200
commit6f398aa76248dfdbd1ea31b8ef32431be0f762ee (patch)
treee9c8f6380fdabb0a5e00b6bdd335c9397e93b6ad /target/linux/oxnas/patches-4.4/300-introduce-oxnas-platform.patch
parentd6ee5e462c34a337a1b53994df5581a507e2c342 (diff)
downloadupstream-6f398aa76248dfdbd1ea31b8ef32431be0f762ee.tar.gz
upstream-6f398aa76248dfdbd1ea31b8ef32431be0f762ee.tar.bz2
upstream-6f398aa76248dfdbd1ea31b8ef32431be0f762ee.zip
oxnas: reboot target
Reboot the oxnas target based on Linux 4.14 by rebasing our support on top of the now-existing upstream kernel support. This commit brings oxnas support to the level of v4.17 having upstream drivers for Ethernet, Serial and NAND flash. Botch up OpenWrt's local drivers for EHCI, SATA and PCIe based on the new platform code and device-tree. Re-introduce base-files from old oxnas target which works for now but needs further clean-up towards generic board support. Functional issues: * PCIe won't come up (hence no USB3 on Shuttle KD20) * I2C bus of Akitio myCloud device is likely not to work (missing debounce support in new pinctrl driver) Code-style issues: * plla/pllb needs further cleanup -- currently their users are writing into the syscon regmap after acquireling the clk instead of using defined clk_*_*() functions to setup multipliers and dividors. * PCIe phy needs its own little driver. * SATA driver is a monster and should be split into an mfd having a raidctrl regmap, sata controller, sata ports and sata phy. Tested on MitraStar STG-212 aka. Medion Akoya MD86xxx and Shuttle KD20. Signed-off-by: Daniel Golle <daniel@makrotopia.org> (squash-picked commit 17511a7ea8 and commit dcc34574ef from master)
Diffstat (limited to 'target/linux/oxnas/patches-4.4/300-introduce-oxnas-platform.patch')
-rw-r--r--target/linux/oxnas/patches-4.4/300-introduce-oxnas-platform.patch71
1 files changed, 0 insertions, 71 deletions
diff --git a/target/linux/oxnas/patches-4.4/300-introduce-oxnas-platform.patch b/target/linux/oxnas/patches-4.4/300-introduce-oxnas-platform.patch
deleted file mode 100644
index a88d5d94b5..0000000000
--- a/target/linux/oxnas/patches-4.4/300-introduce-oxnas-platform.patch
+++ /dev/null
@@ -1,71 +0,0 @@
---- a/arch/arm/Kconfig
-+++ b/arch/arm/Kconfig
-@@ -603,6 +603,19 @@ config ARCH_LPC32XX
- help
- Support for the NXP LPC32XX family of processors
-
-+config ARCH_OXNAS
-+ bool "Oxford Semiconductor 815/820/825 NAS SoC"
-+ select ARM_GIC
-+ select ARCH_REQUIRE_GPIOLIB
-+ select CLKDEV_LOOKUP
-+ select GENERIC_CLOCKEVENTS
-+ select COMMON_CLK
-+ select MIGHT_HAVE_PCI
-+ select ARCH_HAS_RESET_CONTROLLER
-+ help
-+ This enables support for Oxford 815/820/825 NAS SoC
-+ later renamed to PLXTECH NAS782x.
-+
- config ARCH_PXA
- bool "PXA2xx/PXA3xx-based"
- depends on MMU
-@@ -883,6 +896,8 @@ source "arch/arm/mach-omap2/Kconfig"
-
- source "arch/arm/mach-orion5x/Kconfig"
-
-+source "arch/arm/mach-oxnas/Kconfig"
-+
- source "arch/arm/mach-picoxcell/Kconfig"
-
- source "arch/arm/mach-pxa/Kconfig"
---- a/arch/arm/Makefile
-+++ b/arch/arm/Makefile
-@@ -200,6 +200,7 @@ machine-$(CONFIG_ARCH_NSPIRE) += nspire
- machine-$(CONFIG_ARCH_OMAP1) += omap1
- machine-$(CONFIG_ARCH_OMAP2PLUS) += omap2
- machine-$(CONFIG_ARCH_ORION5X) += orion5x
-+machine-$(CONFIG_ARCH_OXNAS) += oxnas
- machine-$(CONFIG_ARCH_PICOXCELL) += picoxcell
- machine-$(CONFIG_ARCH_PXA) += pxa
- machine-$(CONFIG_ARCH_QCOM) += qcom
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -497,6 +497,7 @@ dtb-$(CONFIG_ARCH_ORION5X) += \
- orion5x-lswsgl.dtb \
- orion5x-maxtor-shared-storage-2.dtb \
- orion5x-rd88f5182-nas.dtb
-+dtb-$(CONFIG_ARCH_OXNAS) += ox820-pogoplug-pro.dtb
- dtb-$(CONFIG_ARCH_PRIMA2) += \
- prima2-evb.dtb
- dtb-$(CONFIG_ARCH_QCOM) += \
---- a/arch/arm/tools/mach-types
-+++ b/arch/arm/tools/mach-types
-@@ -228,6 +228,7 @@ edb9302a MACH_EDB9302A EDB9302A 1127
- edb9307a MACH_EDB9307A EDB9307A 1128
- omap_3430sdp MACH_OMAP_3430SDP OMAP_3430SDP 1138
- vstms MACH_VSTMS VSTMS 1140
-+ox820 MACH_OX820 OX820 1152
- micro9m MACH_MICRO9M MICRO9M 1169
- bug MACH_BUG BUG 1179
- at91sam9263ek MACH_AT91SAM9263EK AT91SAM9263EK 1202
---- a/drivers/clk/Makefile
-+++ b/drivers/clk/Makefile
-@@ -32,6 +32,7 @@ obj-$(CONFIG_ARCH_MB86S7X) += clk-mb86s
- obj-$(CONFIG_ARCH_MOXART) += clk-moxart.o
- obj-$(CONFIG_ARCH_NOMADIK) += clk-nomadik.o
- obj-$(CONFIG_ARCH_NSPIRE) += clk-nspire.o
-+obj-$(CONFIG_ARCH_OXNAS) += clk-oxnas.o
- obj-$(CONFIG_COMMON_CLK_PALMAS) += clk-palmas.o
- obj-$(CONFIG_CLK_QORIQ) += clk-qoriq.o
- obj-$(CONFIG_COMMON_CLK_RK808) += clk-rk808.o