aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-03-02 11:26:00 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-03-06 19:21:03 +0100
commit5ea1b1ecd14793c547cb141d149e43aa954e99fb (patch)
treefd4c5732cf6716dcafcc703bd365b7a565d1b385 /target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch
parent0b84b892516942f1b78e53665168c81aaa7f5256 (diff)
downloadupstream-5ea1b1ecd14793c547cb141d149e43aa954e99fb.tar.gz
upstream-5ea1b1ecd14793c547cb141d149e43aa954e99fb.tar.bz2
upstream-5ea1b1ecd14793c547cb141d149e43aa954e99fb.zip
oxnas: add 5.4 as testing kernel version
Add 5.4 kernel version as a new testing kernel option. Run-tested on Shuttle KD20, seems to work just as well as kernel 4.14. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch')
-rw-r--r--target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch b/target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch
index a6b7137584..2a4e4536dc 100644
--- a/target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch
+++ b/target/linux/oxnas/patches-4.14/340-oxnas-pcie.patch
@@ -1,5 +1,5 @@
---- a/drivers/pci/host/Kconfig
-+++ b/drivers/pci/host/Kconfig
+--- a/drivers/pci/controller/Kconfig
++++ b/drivers/pci/controller/Kconfig
@@ -220,4 +220,9 @@ config VMD
To compile this driver as a module, choose M here: the
module will be called vmd.
@@ -10,8 +10,8 @@
+ select PCIEPORTBUS
+
endmenu
---- a/drivers/pci/host/Makefile
-+++ b/drivers/pci/host/Makefile
+--- a/drivers/pci/controller/Makefile
++++ b/drivers/pci/controller/Makefile
@@ -20,6 +20,7 @@ obj-$(CONFIG_PCIE_ALTERA) += pcie-altera
obj-$(CONFIG_PCIE_ALTERA_MSI) += pcie-altera-msi.o
obj-$(CONFIG_PCIE_ROCKCHIP) += pcie-rockchip.o