aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.1/800-oxnas-ehci.patch
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-07-18 18:32:48 +0200
committerDaniel Golle <daniel@makrotopia.org>2016-07-18 18:35:32 +0200
commitc5ec5e1f7f33a18ea81d3d9254c5b49bbdfd5e16 (patch)
treed3f814a4a85f72d5093ba49c3518c8e7e46e9f33 /target/linux/oxnas/patches-4.1/800-oxnas-ehci.patch
parent56f686b7107b17341e6357e31435237e6fb1bb0c (diff)
downloadupstream-c5ec5e1f7f33a18ea81d3d9254c5b49bbdfd5e16.tar.gz
upstream-c5ec5e1f7f33a18ea81d3d9254c5b49bbdfd5e16.tar.bz2
upstream-c5ec5e1f7f33a18ea81d3d9254c5b49bbdfd5e16.zip
oxnas: revert to kernel 4.1
A bug resulting in the NAND not being detected by newer kernels has kept me sleepless for months and yet I wasn't able to discover the cause. Bring back patches and files for 4.1 until this has been resolved. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/oxnas/patches-4.1/800-oxnas-ehci.patch')
-rw-r--r--target/linux/oxnas/patches-4.1/800-oxnas-ehci.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.1/800-oxnas-ehci.patch b/target/linux/oxnas/patches-4.1/800-oxnas-ehci.patch
new file mode 100644
index 0000000000..b283bbd3f6
--- /dev/null
+++ b/target/linux/oxnas/patches-4.1/800-oxnas-ehci.patch
@@ -0,0 +1,26 @@
+--- a/drivers/usb/host/Kconfig
++++ b/drivers/usb/host/Kconfig
+@@ -313,6 +313,13 @@ config USB_OCTEON_EHCI
+ USB 2.0 device support. All CN6XXX based chips with USB are
+ supported.
+
++config USB_EHCI_OXNAS
++ tristate "OXNAS EHCI Module"
++ depends on USB_EHCI_HCD && ARCH_OXNAS
++ select USB_EHCI_ROOT_HUB_TT
++ ---help---
++ Enable support for the OX820 SOC's on-chip EHCI controller.
++
+ endif # USB_EHCI_HCD
+
+ config USB_OXU210HP_HCD
+--- a/drivers/usb/host/Makefile
++++ b/drivers/usb/host/Makefile
+@@ -42,6 +42,7 @@ obj-$(CONFIG_USB_EHCI_HCD_AT91) += ehci-
+ obj-$(CONFIG_USB_EHCI_MSM) += ehci-msm.o
+ obj-$(CONFIG_USB_EHCI_TEGRA) += ehci-tegra.o
+ obj-$(CONFIG_USB_W90X900_EHCI) += ehci-w90x900.o
++obj-$(CONFIG_USB_EHCI_OXNAS) += ehci-oxnas.o
+
+ obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o
+ obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o