aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.1/500-oxnas-sata.patch
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-07-18 18:32:48 +0200
committerDaniel Golle <daniel@makrotopia.org>2016-07-18 18:35:32 +0200
commitc5ec5e1f7f33a18ea81d3d9254c5b49bbdfd5e16 (patch)
treed3f814a4a85f72d5093ba49c3518c8e7e46e9f33 /target/linux/oxnas/patches-4.1/500-oxnas-sata.patch
parent56f686b7107b17341e6357e31435237e6fb1bb0c (diff)
downloadupstream-c5ec5e1f7f33a18ea81d3d9254c5b49bbdfd5e16.tar.gz
upstream-c5ec5e1f7f33a18ea81d3d9254c5b49bbdfd5e16.tar.bz2
upstream-c5ec5e1f7f33a18ea81d3d9254c5b49bbdfd5e16.zip
oxnas: revert to kernel 4.1
A bug resulting in the NAND not being detected by newer kernels has kept me sleepless for months and yet I wasn't able to discover the cause. Bring back patches and files for 4.1 until this has been resolved. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/oxnas/patches-4.1/500-oxnas-sata.patch')
-rw-r--r--target/linux/oxnas/patches-4.1/500-oxnas-sata.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.1/500-oxnas-sata.patch b/target/linux/oxnas/patches-4.1/500-oxnas-sata.patch
new file mode 100644
index 0000000000..8c59b219fd
--- /dev/null
+++ b/target/linux/oxnas/patches-4.1/500-oxnas-sata.patch
@@ -0,0 +1,26 @@
+--- a/drivers/ata/Kconfig
++++ b/drivers/ata/Kconfig
+@@ -402,6 +402,13 @@ config SATA_VITESSE
+
+ If unsure, say N.
+
++config SATA_OXNAS
++ tristate "PLXTECH NAS782X SATA support"
++ help
++ This option enables support for Nas782x Serial ATA controller.
++
++ If unsure, say N.
++
+ comment "PATA SFF controllers with BMDMA"
+
+ config PATA_ALI
+--- a/drivers/ata/Makefile
++++ b/drivers/ata/Makefile
+@@ -37,6 +37,7 @@ obj-$(CONFIG_SATA_SVW) += sata_svw.o
+ obj-$(CONFIG_SATA_ULI) += sata_uli.o
+ obj-$(CONFIG_SATA_VIA) += sata_via.o
+ obj-$(CONFIG_SATA_VITESSE) += sata_vsc.o
++obj-$(CONFIG_SATA_OXNAS) += sata_oxnas.o
+
+ # SFF PATA w/ BMDMA
+ obj-$(CONFIG_PATA_ALI) += pata_ali.o