aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.1/350-oxnas-reset.patch
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-07-18 18:32:48 +0200
committerDaniel Golle <daniel@makrotopia.org>2016-07-18 18:35:32 +0200
commitc5ec5e1f7f33a18ea81d3d9254c5b49bbdfd5e16 (patch)
treed3f814a4a85f72d5093ba49c3518c8e7e46e9f33 /target/linux/oxnas/patches-4.1/350-oxnas-reset.patch
parent56f686b7107b17341e6357e31435237e6fb1bb0c (diff)
downloadupstream-c5ec5e1f7f33a18ea81d3d9254c5b49bbdfd5e16.tar.gz
upstream-c5ec5e1f7f33a18ea81d3d9254c5b49bbdfd5e16.tar.bz2
upstream-c5ec5e1f7f33a18ea81d3d9254c5b49bbdfd5e16.zip
oxnas: revert to kernel 4.1
A bug resulting in the NAND not being detected by newer kernels has kept me sleepless for months and yet I wasn't able to discover the cause. Bring back patches and files for 4.1 until this has been resolved. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/oxnas/patches-4.1/350-oxnas-reset.patch')
-rw-r--r--target/linux/oxnas/patches-4.1/350-oxnas-reset.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.1/350-oxnas-reset.patch b/target/linux/oxnas/patches-4.1/350-oxnas-reset.patch
new file mode 100644
index 0000000000..1cecd28dc7
--- /dev/null
+++ b/target/linux/oxnas/patches-4.1/350-oxnas-reset.patch
@@ -0,0 +1,20 @@
+--- a/drivers/reset/Kconfig
++++ b/drivers/reset/Kconfig
+@@ -12,4 +12,9 @@ menuconfig RESET_CONTROLLER
+
+ If unsure, say no.
+
++config RESET_CONTROLLER_OXNAS
++ bool
++ select RESET_CONTROLLER
++
+ source "drivers/reset/sti/Kconfig"
++
+--- a/drivers/reset/Makefile
++++ b/drivers/reset/Makefile
+@@ -1,4 +1,5 @@
+ obj-$(CONFIG_RESET_CONTROLLER) += core.o
++obj-$(CONFIG_RESET_CONTROLLER_OXNAS) += reset-ox820.o
+ obj-$(CONFIG_ARCH_SOCFPGA) += reset-socfpga.o
+ obj-$(CONFIG_ARCH_BERLIN) += reset-berlin.o
+ obj-$(CONFIG_ARCH_SUNXI) += reset-sunxi.o