aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.0/500-oxnas-sata.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-03-21 21:47:03 +0000
committerJohn Crispin <blogic@openwrt.org>2015-03-21 21:47:03 +0000
commitd4a4c0aefc7089ee345ea171a9b2ef28a6254d7d (patch)
tree733704ed5944337872d5ba5c1c37dfbbd1cdbcb6 /target/linux/oxnas/patches-4.0/500-oxnas-sata.patch
parentca37f8bd1100a165a3f81865710f40c8c60d4275 (diff)
downloadupstream-d4a4c0aefc7089ee345ea171a9b2ef28a6254d7d.tar.gz
upstream-d4a4c0aefc7089ee345ea171a9b2ef28a6254d7d.tar.bz2
upstream-d4a4c0aefc7089ee345ea171a9b2ef28a6254d7d.zip
oxnas: add support for kernel 4.0
Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44922 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/oxnas/patches-4.0/500-oxnas-sata.patch')
-rw-r--r--target/linux/oxnas/patches-4.0/500-oxnas-sata.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.0/500-oxnas-sata.patch b/target/linux/oxnas/patches-4.0/500-oxnas-sata.patch
new file mode 100644
index 0000000000..c9b11e99d8
--- /dev/null
+++ b/target/linux/oxnas/patches-4.0/500-oxnas-sata.patch
@@ -0,0 +1,30 @@
+Index: linux-4.0-rc4/drivers/ata/Kconfig
+===================================================================
+--- linux-4.0-rc4.orig/drivers/ata/Kconfig
++++ linux-4.0-rc4/drivers/ata/Kconfig
+@@ -401,6 +401,13 @@ config SATA_VITESSE
+
+ If unsure, say N.
+
++config SATA_OXNAS
++ tristate "PLXTECH NAS782X SATA support"
++ help
++ This option enables support for Nas782x Serial ATA controller.
++
++ If unsure, say N.
++
+ comment "PATA SFF controllers with BMDMA"
+
+ config PATA_ALI
+Index: linux-4.0-rc4/drivers/ata/Makefile
+===================================================================
+--- linux-4.0-rc4.orig/drivers/ata/Makefile
++++ linux-4.0-rc4/drivers/ata/Makefile
+@@ -37,6 +37,7 @@ obj-$(CONFIG_SATA_SVW) += sata_svw.o
+ obj-$(CONFIG_SATA_ULI) += sata_uli.o
+ obj-$(CONFIG_SATA_VIA) += sata_via.o
+ obj-$(CONFIG_SATA_VITESSE) += sata_vsc.o
++obj-$(CONFIG_SATA_OXNAS) += sata_oxnas.o
+
+ # SFF PATA w/ BMDMA
+ obj-$(CONFIG_PATA_ALI) += pata_ali.o