aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.0/400-oxnas-nand.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-21 21:47:03 +0000
committerJohn Crispin <john@openwrt.org>2015-03-21 21:47:03 +0000
commit3256194aff475c16a0804690eff105a384e7307b (patch)
tree473fd150f89a1845fe22ad28c2890ddeb4d864bb /target/linux/oxnas/patches-4.0/400-oxnas-nand.patch
parent908a82ab61ae1c7b09bbe5c64d8d1001db208a24 (diff)
downloadupstream-3256194aff475c16a0804690eff105a384e7307b.tar.gz
upstream-3256194aff475c16a0804690eff105a384e7307b.tar.bz2
upstream-3256194aff475c16a0804690eff105a384e7307b.zip
oxnas: add support for kernel 4.0
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 44922
Diffstat (limited to 'target/linux/oxnas/patches-4.0/400-oxnas-nand.patch')
-rw-r--r--target/linux/oxnas/patches-4.0/400-oxnas-nand.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.0/400-oxnas-nand.patch b/target/linux/oxnas/patches-4.0/400-oxnas-nand.patch
new file mode 100644
index 0000000000..555b715501
--- /dev/null
+++ b/target/linux/oxnas/patches-4.0/400-oxnas-nand.patch
@@ -0,0 +1,29 @@
+Index: linux-4.0-rc4/drivers/mtd/nand/Kconfig
+===================================================================
+--- linux-4.0-rc4.orig/drivers/mtd/nand/Kconfig
++++ linux-4.0-rc4/drivers/mtd/nand/Kconfig
+@@ -530,4 +530,12 @@ config MTD_NAND_HISI504
+ help
+ Enables support for NAND controller on Hisilicon SoC Hip04.
+
++config MTD_NAND_OXNAS
++ tristate "Support for NAND on Plxtech NAS782X SoC"
++ depends on ARCH_OXNAS
++ select MTD_NAND_PLATFORM
++ help
++ Enables support for NAND Flash chips on Plxtech NAS782X SoCs. NAND is attached
++ to the STATIC Unit.
++
+ endif # MTD_NAND
+Index: linux-4.0-rc4/drivers/mtd/nand/Makefile
+===================================================================
+--- linux-4.0-rc4.orig/drivers/mtd/nand/Makefile
++++ linux-4.0-rc4/drivers/mtd/nand/Makefile
+@@ -45,6 +45,7 @@ obj-$(CONFIG_MTD_NAND_SOCRATES) += socr
+ obj-$(CONFIG_MTD_NAND_TXX9NDFMC) += txx9ndfmc.o
+ obj-$(CONFIG_MTD_NAND_NUC900) += nuc900_nand.o
+ obj-$(CONFIG_MTD_NAND_MPC5121_NFC) += mpc5121_nfc.o
++obj-$(CONFIG_MTD_NAND_OXNAS) += oxnas_nand.o
+ obj-$(CONFIG_MTD_NAND_RICOH) += r852.o
+ obj-$(CONFIG_MTD_NAND_JZ4740) += jz4740_nand.o
+ obj-$(CONFIG_MTD_NAND_GPMI_NAND) += gpmi-nand/