aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.0/340-oxnas-pcie.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-21 21:47:03 +0000
committerJohn Crispin <john@openwrt.org>2015-03-21 21:47:03 +0000
commit3256194aff475c16a0804690eff105a384e7307b (patch)
tree473fd150f89a1845fe22ad28c2890ddeb4d864bb /target/linux/oxnas/patches-4.0/340-oxnas-pcie.patch
parent908a82ab61ae1c7b09bbe5c64d8d1001db208a24 (diff)
downloadupstream-3256194aff475c16a0804690eff105a384e7307b.tar.gz
upstream-3256194aff475c16a0804690eff105a384e7307b.tar.bz2
upstream-3256194aff475c16a0804690eff105a384e7307b.zip
oxnas: add support for kernel 4.0
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 44922
Diffstat (limited to 'target/linux/oxnas/patches-4.0/340-oxnas-pcie.patch')
-rw-r--r--target/linux/oxnas/patches-4.0/340-oxnas-pcie.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.0/340-oxnas-pcie.patch b/target/linux/oxnas/patches-4.0/340-oxnas-pcie.patch
new file mode 100644
index 0000000000..a105f61740
--- /dev/null
+++ b/target/linux/oxnas/patches-4.0/340-oxnas-pcie.patch
@@ -0,0 +1,26 @@
+Index: linux-4.0-rc4/drivers/pci/host/Kconfig
+===================================================================
+--- linux-4.0-rc4.orig/drivers/pci/host/Kconfig
++++ linux-4.0-rc4/drivers/pci/host/Kconfig
+@@ -106,4 +106,9 @@ config PCI_VERSATILE
+ bool "ARM Versatile PB PCI controller"
+ depends on ARCH_VERSATILE
+
++config PCI_OXNAS
++ bool "PLX Oxnas PCIe controller"
++ depends on ARCH_OXNAS
++ select PCIEPORTBUS
++
+ endmenu
+Index: linux-4.0-rc4/drivers/pci/host/Makefile
+===================================================================
+--- linux-4.0-rc4.orig/drivers/pci/host/Makefile
++++ linux-4.0-rc4/drivers/pci/host/Makefile
+@@ -3,6 +3,7 @@ obj-$(CONFIG_PCI_DRA7XX) += pci-dra7xx.o
+ obj-$(CONFIG_PCI_EXYNOS) += pci-exynos.o
+ obj-$(CONFIG_PCI_IMX6) += pci-imx6.o
+ obj-$(CONFIG_PCI_MVEBU) += pci-mvebu.o
++obj-$(CONFIG_PCI_OXNAS) += pcie-oxnas.o
+ obj-$(CONFIG_PCI_TEGRA) += pci-tegra.o
+ obj-$(CONFIG_PCI_RCAR_GEN2) += pci-rcar-gen2.o
+ obj-$(CONFIG_PCI_RCAR_GEN2_PCIE) += pcie-rcar.o