aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.0/340-oxnas-pcie.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-03-21 21:47:03 +0000
committerJohn Crispin <blogic@openwrt.org>2015-03-21 21:47:03 +0000
commitd4a4c0aefc7089ee345ea171a9b2ef28a6254d7d (patch)
tree733704ed5944337872d5ba5c1c37dfbbd1cdbcb6 /target/linux/oxnas/patches-4.0/340-oxnas-pcie.patch
parentca37f8bd1100a165a3f81865710f40c8c60d4275 (diff)
downloadupstream-d4a4c0aefc7089ee345ea171a9b2ef28a6254d7d.tar.gz
upstream-d4a4c0aefc7089ee345ea171a9b2ef28a6254d7d.tar.bz2
upstream-d4a4c0aefc7089ee345ea171a9b2ef28a6254d7d.zip
oxnas: add support for kernel 4.0
Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44922 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/oxnas/patches-4.0/340-oxnas-pcie.patch')
-rw-r--r--target/linux/oxnas/patches-4.0/340-oxnas-pcie.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.0/340-oxnas-pcie.patch b/target/linux/oxnas/patches-4.0/340-oxnas-pcie.patch
new file mode 100644
index 0000000000..a105f61740
--- /dev/null
+++ b/target/linux/oxnas/patches-4.0/340-oxnas-pcie.patch
@@ -0,0 +1,26 @@
+Index: linux-4.0-rc4/drivers/pci/host/Kconfig
+===================================================================
+--- linux-4.0-rc4.orig/drivers/pci/host/Kconfig
++++ linux-4.0-rc4/drivers/pci/host/Kconfig
+@@ -106,4 +106,9 @@ config PCI_VERSATILE
+ bool "ARM Versatile PB PCI controller"
+ depends on ARCH_VERSATILE
+
++config PCI_OXNAS
++ bool "PLX Oxnas PCIe controller"
++ depends on ARCH_OXNAS
++ select PCIEPORTBUS
++
+ endmenu
+Index: linux-4.0-rc4/drivers/pci/host/Makefile
+===================================================================
+--- linux-4.0-rc4.orig/drivers/pci/host/Makefile
++++ linux-4.0-rc4/drivers/pci/host/Makefile
+@@ -3,6 +3,7 @@ obj-$(CONFIG_PCI_DRA7XX) += pci-dra7xx.o
+ obj-$(CONFIG_PCI_EXYNOS) += pci-exynos.o
+ obj-$(CONFIG_PCI_IMX6) += pci-imx6.o
+ obj-$(CONFIG_PCI_MVEBU) += pci-mvebu.o
++obj-$(CONFIG_PCI_OXNAS) += pcie-oxnas.o
+ obj-$(CONFIG_PCI_TEGRA) += pci-tegra.o
+ obj-$(CONFIG_PCI_RCAR_GEN2) += pci-rcar-gen2.o
+ obj-$(CONFIG_PCI_RCAR_GEN2_PCIE) += pcie-rcar.o