aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.0/330-oxnas-pinctrl.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-21 21:47:03 +0000
committerJohn Crispin <john@openwrt.org>2015-03-21 21:47:03 +0000
commit3256194aff475c16a0804690eff105a384e7307b (patch)
tree473fd150f89a1845fe22ad28c2890ddeb4d864bb /target/linux/oxnas/patches-4.0/330-oxnas-pinctrl.patch
parent908a82ab61ae1c7b09bbe5c64d8d1001db208a24 (diff)
downloadupstream-3256194aff475c16a0804690eff105a384e7307b.tar.gz
upstream-3256194aff475c16a0804690eff105a384e7307b.tar.bz2
upstream-3256194aff475c16a0804690eff105a384e7307b.zip
oxnas: add support for kernel 4.0
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 44922
Diffstat (limited to 'target/linux/oxnas/patches-4.0/330-oxnas-pinctrl.patch')
-rw-r--r--target/linux/oxnas/patches-4.0/330-oxnas-pinctrl.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.0/330-oxnas-pinctrl.patch b/target/linux/oxnas/patches-4.0/330-oxnas-pinctrl.patch
new file mode 100644
index 0000000000..c037d7271d
--- /dev/null
+++ b/target/linux/oxnas/patches-4.0/330-oxnas-pinctrl.patch
@@ -0,0 +1,32 @@
+Index: linux-4.0-rc4/drivers/pinctrl/Kconfig
+===================================================================
+--- linux-4.0-rc4.orig/drivers/pinctrl/Kconfig
++++ linux-4.0-rc4/drivers/pinctrl/Kconfig
+@@ -188,6 +188,15 @@ config PINCTRL_COH901
+ COH 901 335 and COH 901 571/3. They contain 3, 5 or 7
+ ports of 8 GPIO pins each.
+
++config PINCTRL_OXNAS
++ bool "OXNAS pinctrl driver"
++ depends on OF
++ depends on ARCH_OXNAS
++ select PINMUX
++ select PINCONF
++ help
++ Say Y here to enable the oxnas pinctrl driver
++
+ config PINCTRL_PALMAS
+ bool "Pinctrl driver for the PALMAS Series MFD devices"
+ depends on OF && MFD_PALMAS
+Index: linux-4.0-rc4/drivers/pinctrl/Makefile
+===================================================================
+--- linux-4.0-rc4.orig/drivers/pinctrl/Makefile
++++ linux-4.0-rc4/drivers/pinctrl/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_PINCTRL_BCM2835) += pinctrl
+ obj-$(CONFIG_PINCTRL_BCM281XX) += pinctrl-bcm281xx.o
+ obj-$(CONFIG_PINCTRL_FALCON) += pinctrl-falcon.o
+ obj-$(CONFIG_PINCTRL_MESON) += meson/
++obj-$(CONFIG_PINCTRL_OXNAS) += pinctrl-oxnas.o
+ obj-$(CONFIG_PINCTRL_PALMAS) += pinctrl-palmas.o
+ obj-$(CONFIG_PINCTRL_ROCKCHIP) += pinctrl-rockchip.o
+ obj-$(CONFIG_PINCTRL_SINGLE) += pinctrl-single.o