aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-4.0/300-introduce-oxnas-platform.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-21 21:47:03 +0000
committerJohn Crispin <john@openwrt.org>2015-03-21 21:47:03 +0000
commit3256194aff475c16a0804690eff105a384e7307b (patch)
tree473fd150f89a1845fe22ad28c2890ddeb4d864bb /target/linux/oxnas/patches-4.0/300-introduce-oxnas-platform.patch
parent908a82ab61ae1c7b09bbe5c64d8d1001db208a24 (diff)
downloadupstream-3256194aff475c16a0804690eff105a384e7307b.tar.gz
upstream-3256194aff475c16a0804690eff105a384e7307b.tar.bz2
upstream-3256194aff475c16a0804690eff105a384e7307b.zip
oxnas: add support for kernel 4.0
Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 44922
Diffstat (limited to 'target/linux/oxnas/patches-4.0/300-introduce-oxnas-platform.patch')
-rw-r--r--target/linux/oxnas/patches-4.0/300-introduce-oxnas-platform.patch79
1 files changed, 79 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-4.0/300-introduce-oxnas-platform.patch b/target/linux/oxnas/patches-4.0/300-introduce-oxnas-platform.patch
new file mode 100644
index 0000000000..465e5b7c47
--- /dev/null
+++ b/target/linux/oxnas/patches-4.0/300-introduce-oxnas-platform.patch
@@ -0,0 +1,79 @@
+Index: linux-4.0-rc4/arch/arm/Kconfig
+===================================================================
+--- linux-4.0-rc4.orig/arch/arm/Kconfig
++++ linux-4.0-rc4/arch/arm/Kconfig
+@@ -356,6 +356,17 @@ config ARCH_VERSATILE
+ help
+ This enables support for ARM Ltd Versatile board.
+
++config ARCH_OXNAS
++ bool "Oxford Semiconductor 815/820/825 NAS SoC"
++ select ARCH_REQUIRE_GPIOLIB
++ select CLKDEV_LOOKUP
++ select GENERIC_CLOCKEVENTS
++ select COMMON_CLK
++ select MIGHT_HAVE_PCI
++ select ARCH_HAS_RESET_CONTROLLER
++ help
++ This enables support for Oxsemi 815/820/825 NAS SoC
++
+ config ARCH_AT91
+ bool "Atmel AT91"
+ select ARCH_REQUIRE_GPIOLIB
+@@ -916,6 +927,8 @@ source "arch/arm/mach-omap2/Kconfig"
+
+ source "arch/arm/mach-orion5x/Kconfig"
+
++source "arch/arm/mach-oxnas/Kconfig"
++
+ source "arch/arm/mach-picoxcell/Kconfig"
+
+ source "arch/arm/mach-pxa/Kconfig"
+Index: linux-4.0-rc4/arch/arm/Makefile
+===================================================================
+--- linux-4.0-rc4.orig/arch/arm/Makefile
++++ linux-4.0-rc4/arch/arm/Makefile
+@@ -188,6 +188,7 @@ machine-$(CONFIG_ARCH_NSPIRE) += nspire
+ machine-$(CONFIG_ARCH_OMAP1) += omap1
+ machine-$(CONFIG_ARCH_OMAP2PLUS) += omap2
+ machine-$(CONFIG_ARCH_ORION5X) += orion5x
++machine-$(CONFIG_ARCH_OXNAS) += oxnas
+ machine-$(CONFIG_ARCH_PICOXCELL) += picoxcell
+ machine-$(CONFIG_ARCH_PXA) += pxa
+ machine-$(CONFIG_ARCH_QCOM) += qcom
+Index: linux-4.0-rc4/arch/arm/boot/dts/Makefile
+===================================================================
+--- linux-4.0-rc4.orig/arch/arm/boot/dts/Makefile
++++ linux-4.0-rc4/arch/arm/boot/dts/Makefile
+@@ -429,6 +429,7 @@ dtb-$(CONFIG_ARCH_ORION5X) += \
+ orion5x-lacie-ethernet-disk-mini-v2.dtb \
+ orion5x-maxtor-shared-storage-2.dtb \
+ orion5x-rd88f5182-nas.dtb
++dtb-$(CONFIG_ARCH_OXNAS) += ox820-pogoplug-pro.dtb
+ dtb-$(CONFIG_ARCH_PRIMA2) += \
+ prima2-evb.dtb
+ dtb-$(CONFIG_ARCH_QCOM) += \
+Index: linux-4.0-rc4/arch/arm/tools/mach-types
+===================================================================
+--- linux-4.0-rc4.orig/arch/arm/tools/mach-types
++++ linux-4.0-rc4/arch/arm/tools/mach-types
+@@ -228,6 +228,7 @@ edb9302a MACH_EDB9302A EDB9302A 1127
+ edb9307a MACH_EDB9307A EDB9307A 1128
+ omap_3430sdp MACH_OMAP_3430SDP OMAP_3430SDP 1138
+ vstms MACH_VSTMS VSTMS 1140
++ox820 MACH_OX820 OX820 1152
+ micro9m MACH_MICRO9M MICRO9M 1169
+ bug MACH_BUG BUG 1179
+ at91sam9263ek MACH_AT91SAM9263EK AT91SAM9263EK 1202
+Index: linux-4.0-rc4/drivers/clk/Makefile
+===================================================================
+--- linux-4.0-rc4.orig/drivers/clk/Makefile
++++ linux-4.0-rc4/drivers/clk/Makefile
+@@ -31,6 +31,7 @@ obj-$(CONFIG_COMMON_CLK_MAX77802) += clk
+ obj-$(CONFIG_ARCH_MOXART) += clk-moxart.o
+ obj-$(CONFIG_ARCH_NOMADIK) += clk-nomadik.o
+ obj-$(CONFIG_ARCH_NSPIRE) += clk-nspire.o
++obj-$(CONFIG_ARCH_OXNAS) += clk-oxnas.o
+ obj-$(CONFIG_COMMON_CLK_PALMAS) += clk-palmas.o
+ obj-$(CONFIG_CLK_QORIQ) += clk-qoriq.o
+ obj-$(CONFIG_COMMON_CLK_RK808) += clk-rk808.o