aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-3.18/500-oxnas-sata.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-11-26 09:00:08 +0000
committerJohn Crispin <blogic@openwrt.org>2014-11-26 09:00:08 +0000
commit7d4dfd7dd7ce1ac02d84ad7482e3f7d168d61ec9 (patch)
tree24af078d708bfb6b3027ff4064114d439e4213e1 /target/linux/oxnas/patches-3.18/500-oxnas-sata.patch
parent2088d1ea438e14be13e9d579ebf847f9cc50245d (diff)
downloadupstream-7d4dfd7dd7ce1ac02d84ad7482e3f7d168d61ec9.tar.gz
upstream-7d4dfd7dd7ce1ac02d84ad7482e3f7d168d61ec9.tar.bz2
upstream-7d4dfd7dd7ce1ac02d84ad7482e3f7d168d61ec9.zip
add new target 'oxnas'
This is the oxnas target previously developed at http://gitorious.org/openwrt-oxnas Basically, this consolidates the changes and addtionas from http://github.org/kref/linux-oxnas into a new OpenWrt hardware target 'oxnas' adding support for PLX Technology NAS7820/NAS7821/NAS7825/... formally known as Oxford Semiconductor OXE810SE/OXE815/OX820/... For now there are 4 supported boards: Cloud Engines Pogoplug V3 (without PCIe) fully supported Cloud Engines Pogoplug Pro (with PCIe) fully supported MitraStar STG-212 aka ZyXEL NSA-212, aka Medion Akoya P89625 / P89636 / P89626 / P89630, aka Medion MD 86407 / MD 86805 / MD 86517 / MD 86587 fully supported, see http://wiki.openwrt.org/toh/medion/md86587 Shuttle KD-20 partially supported (S-ATA driver lacks support for 2nd port) Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43388 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/oxnas/patches-3.18/500-oxnas-sata.patch')
-rw-r--r--target/linux/oxnas/patches-3.18/500-oxnas-sata.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-3.18/500-oxnas-sata.patch b/target/linux/oxnas/patches-3.18/500-oxnas-sata.patch
new file mode 100644
index 0000000000..94b792b136
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/500-oxnas-sata.patch
@@ -0,0 +1,30 @@
+Index: linux-3.18-rc4/drivers/ata/Kconfig
+===================================================================
+--- linux-3.18-rc4.orig/drivers/ata/Kconfig
++++ linux-3.18-rc4/drivers/ata/Kconfig
+@@ -385,6 +385,13 @@ config SATA_VITESSE
+
+ If unsure, say N.
+
++config SATA_OXNAS
++ tristate "PLXTECH NAS782X SATA support"
++ help
++ This option enables support for Nas782x Serial ATA controller.
++
++ If unsure, say N.
++
+ comment "PATA SFF controllers with BMDMA"
+
+ config PATA_ALI
+Index: linux-3.18-rc4/drivers/ata/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/drivers/ata/Makefile
++++ linux-3.18-rc4/drivers/ata/Makefile
+@@ -37,6 +37,7 @@ obj-$(CONFIG_SATA_SVW) += sata_svw.o
+ obj-$(CONFIG_SATA_ULI) += sata_uli.o
+ obj-$(CONFIG_SATA_VIA) += sata_via.o
+ obj-$(CONFIG_SATA_VITESSE) += sata_vsc.o
++obj-$(CONFIG_SATA_OXNAS) += sata_oxnas.o
+
+ # SFF PATA w/ BMDMA
+ obj-$(CONFIG_PATA_ALI) += pata_ali.o