aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-3.18/400-oxnas-nand.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-11-26 09:00:08 +0000
committerJohn Crispin <john@openwrt.org>2014-11-26 09:00:08 +0000
commit72b58f2eb12ad4aa0c59481d0911dc5e39180eb5 (patch)
treebe51e2d36c4175443bd3ab42824df80c6b9a2efe /target/linux/oxnas/patches-3.18/400-oxnas-nand.patch
parent40da7aae54ad7f098064f18e28eb8201afedfd5c (diff)
downloadupstream-72b58f2eb12ad4aa0c59481d0911dc5e39180eb5.tar.gz
upstream-72b58f2eb12ad4aa0c59481d0911dc5e39180eb5.tar.bz2
upstream-72b58f2eb12ad4aa0c59481d0911dc5e39180eb5.zip
add new target 'oxnas'
This is the oxnas target previously developed at http://gitorious.org/openwrt-oxnas Basically, this consolidates the changes and addtionas from http://github.org/kref/linux-oxnas into a new OpenWrt hardware target 'oxnas' adding support for PLX Technology NAS7820/NAS7821/NAS7825/... formally known as Oxford Semiconductor OXE810SE/OXE815/OX820/... For now there are 4 supported boards: Cloud Engines Pogoplug V3 (without PCIe) fully supported Cloud Engines Pogoplug Pro (with PCIe) fully supported MitraStar STG-212 aka ZyXEL NSA-212, aka Medion Akoya P89625 / P89636 / P89626 / P89630, aka Medion MD 86407 / MD 86805 / MD 86517 / MD 86587 fully supported, see http://wiki.openwrt.org/toh/medion/md86587 Shuttle KD-20 partially supported (S-ATA driver lacks support for 2nd port) Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43388
Diffstat (limited to 'target/linux/oxnas/patches-3.18/400-oxnas-nand.patch')
-rw-r--r--target/linux/oxnas/patches-3.18/400-oxnas-nand.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-3.18/400-oxnas-nand.patch b/target/linux/oxnas/patches-3.18/400-oxnas-nand.patch
new file mode 100644
index 0000000000..90827e5b8a
--- /dev/null
+++ b/target/linux/oxnas/patches-3.18/400-oxnas-nand.patch
@@ -0,0 +1,28 @@
+Index: linux-3.18-rc4/drivers/mtd/nand/Kconfig
+===================================================================
+--- linux-3.18-rc4.orig/drivers/mtd/nand/Kconfig
++++ linux-3.18-rc4/drivers/mtd/nand/Kconfig
+@@ -516,4 +516,12 @@ config MTD_NAND_XWAY
+ Enables support for NAND Flash chips on Lantiq XWAY SoCs. NAND is attached
+ to the External Bus Unit (EBU).
+
++config MTD_NAND_OXNAS
++ tristate "Support for NAND on Plxtech NAS782X SoC"
++ depends on ARCH_OXNAS
++ select MTD_NAND_PLATFORM
++ help
++ Enables support for NAND Flash chips on Plxtech NAS782X SoCs. NAND is attached
++ to the STATIC Unit.
++
+ endif # MTD_NAND
+Index: linux-3.18-rc4/drivers/mtd/nand/Makefile
+===================================================================
+--- linux-3.18-rc4.orig/drivers/mtd/nand/Makefile
++++ linux-3.18-rc4/drivers/mtd/nand/Makefile
+@@ -50,5 +50,6 @@ obj-$(CONFIG_MTD_NAND_JZ4740) += jz4740
+ obj-$(CONFIG_MTD_NAND_GPMI_NAND) += gpmi-nand/
+ obj-$(CONFIG_MTD_NAND_XWAY) += xway_nand.o
+ obj-$(CONFIG_MTD_NAND_BCM47XXNFLASH) += bcm47xxnflash/
++obj-$(CONFIG_MTD_NAND_OXNAS) += oxnas_nand.o
+
+ nand-objs := nand_base.o nand_bbt.o nand_timings.o