aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-3.14/800-oxnas-ehci.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-12-05 00:20:41 +0000
committerJohn Crispin <john@openwrt.org>2014-12-05 00:20:41 +0000
commite553dfc356b7087e362f0daa283239ee01ae81f5 (patch)
treef91fac0c53ff97a1c3ceabce64fb9dd62933a3d2 /target/linux/oxnas/patches-3.14/800-oxnas-ehci.patch
parentdcc8a8ca9eac90b3e70104c893464c27e62daed5 (diff)
downloadupstream-e553dfc356b7087e362f0daa283239ee01ae81f5.tar.gz
upstream-e553dfc356b7087e362f0daa283239ee01ae81f5.tar.bz2
upstream-e553dfc356b7087e362f0daa283239ee01ae81f5.zip
oxnas: re-add support for kernel 3.14
This reverts commit c81ddddde5fd193802d511b42eb7b108aac17136 on https://gitorious.org/openwrt-oxnas/openwrt-oxnas.git which removed patches and config for 3.14. [arm_introduce-dma-fiq-irq-broadcast patch was renamed to match 3.18] Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43520
Diffstat (limited to 'target/linux/oxnas/patches-3.14/800-oxnas-ehci.patch')
-rw-r--r--target/linux/oxnas/patches-3.14/800-oxnas-ehci.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-3.14/800-oxnas-ehci.patch b/target/linux/oxnas/patches-3.14/800-oxnas-ehci.patch
new file mode 100644
index 0000000000..94e62a910f
--- /dev/null
+++ b/target/linux/oxnas/patches-3.14/800-oxnas-ehci.patch
@@ -0,0 +1,30 @@
+Index: linux-3.14.18/drivers/usb/host/Kconfig
+===================================================================
+--- linux-3.14.18.orig/drivers/usb/host/Kconfig
++++ linux-3.14.18/drivers/usb/host/Kconfig
+@@ -273,6 +273,13 @@ config USB_OCTEON_EHCI
+ USB 2.0 device support. All CN6XXX based chips with USB are
+ supported.
+
++config USB_EHCI_OXNAS
++ tristate "OXNAS EHCI Module"
++ depends on USB_EHCI_HCD && ARCH_OXNAS
++ select USB_EHCI_ROOT_HUB_TT
++ ---help---
++ Enable support for the OX820 SOC's on-chip EHCI controller.
++
+ endif # USB_EHCI_HCD
+
+ config USB_OXU210HP_HCD
+Index: linux-3.14.18/drivers/usb/host/Makefile
+===================================================================
+--- linux-3.14.18.orig/drivers/usb/host/Makefile
++++ linux-3.14.18/drivers/usb/host/Makefile
+@@ -37,6 +37,7 @@ obj-$(CONFIG_USB_EHCI_HCD_AT91) += ehci-
+ obj-$(CONFIG_USB_EHCI_MSM) += ehci-msm.o
+ obj-$(CONFIG_USB_EHCI_TEGRA) += ehci-tegra.o
+ obj-$(CONFIG_USB_W90X900_EHCI) += ehci-w90x900.o
++obj-$(CONFIG_USB_EHCI_OXNAS) += ehci-oxnas.o
+
+ obj-$(CONFIG_USB_OXU210HP_HCD) += oxu210hp-hcd.o
+ obj-$(CONFIG_USB_ISP116X_HCD) += isp116x-hcd.o