aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/modules.mk
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-05-31 17:28:38 +0200
committerDaniel Golle <daniel@makrotopia.org>2018-06-18 18:44:14 +0200
commit6f398aa76248dfdbd1ea31b8ef32431be0f762ee (patch)
treee9c8f6380fdabb0a5e00b6bdd335c9397e93b6ad /target/linux/oxnas/modules.mk
parentd6ee5e462c34a337a1b53994df5581a507e2c342 (diff)
downloadupstream-6f398aa76248dfdbd1ea31b8ef32431be0f762ee.tar.gz
upstream-6f398aa76248dfdbd1ea31b8ef32431be0f762ee.tar.bz2
upstream-6f398aa76248dfdbd1ea31b8ef32431be0f762ee.zip
oxnas: reboot target
Reboot the oxnas target based on Linux 4.14 by rebasing our support on top of the now-existing upstream kernel support. This commit brings oxnas support to the level of v4.17 having upstream drivers for Ethernet, Serial and NAND flash. Botch up OpenWrt's local drivers for EHCI, SATA and PCIe based on the new platform code and device-tree. Re-introduce base-files from old oxnas target which works for now but needs further clean-up towards generic board support. Functional issues: * PCIe won't come up (hence no USB3 on Shuttle KD20) * I2C bus of Akitio myCloud device is likely not to work (missing debounce support in new pinctrl driver) Code-style issues: * plla/pllb needs further cleanup -- currently their users are writing into the syscon regmap after acquireling the clk instead of using defined clk_*_*() functions to setup multipliers and dividors. * PCIe phy needs its own little driver. * SATA driver is a monster and should be split into an mfd having a raidctrl regmap, sata controller, sata ports and sata phy. Tested on MitraStar STG-212 aka. Medion Akoya MD86xxx and Shuttle KD20. Signed-off-by: Daniel Golle <daniel@makrotopia.org> (squash-picked commit 17511a7ea8 and commit dcc34574ef from master)
Diffstat (limited to 'target/linux/oxnas/modules.mk')
-rw-r--r--target/linux/oxnas/modules.mk16
1 files changed, 4 insertions, 12 deletions
diff --git a/target/linux/oxnas/modules.mk b/target/linux/oxnas/modules.mk
index 7016398619..e7c959579b 100644
--- a/target/linux/oxnas/modules.mk
+++ b/target/linux/oxnas/modules.mk
@@ -1,11 +1,3 @@
-#
-# Copyright (C) 2006-2014 OpenWrt.org
-# Copyright (C) 2016 LEDE project
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
define KernelPackage/ata-oxnas-sata
SUBMENU:=$(BLOCK_MENU)
TITLE:=oxnas Serial ATA support
@@ -17,7 +9,7 @@ define KernelPackage/ata-oxnas-sata
endef
define KernelPackage/ata-oxnas-sata/description
- SATA support for OX934 core found in the OX82x/PLX782x SoCs
+ SATA support for OX934 core found in the OX8xx/PLX782x SoCs
endef
$(eval $(call KernelPackage,ata-oxnas-sata))
@@ -25,8 +17,8 @@ $(eval $(call KernelPackage,ata-oxnas-sata))
define KernelPackage/usb2-oxnas
SUBMENU:=$(BLOCK_MENU)
- TITLE:=OXNAS USB controller driver
- DEPENDS:=@TARGET_oxnas +kmod-usb2
+ TITLE:=OX820 EHCI driver
+ DEPENDS:=@TARGET_oxnas_ox820 +kmod-usb2
KCONFIG:=CONFIG_USB_EHCI_OXNAS
FILES:=$(LINUX_DIR)/drivers/usb/host/ehci-oxnas.ko
AUTOLOAD:=$(call AutoLoad,55,ehci-oxnas,1)
@@ -35,7 +27,7 @@ endef
define KernelPackage/usb2-oxnas/description
This driver provides USB Device Controller support for the
- EHCI USB host built-in to the PLXTECH NAS782x SoC
+ EHCI USB host built-in to the OX820 SoC.
endef
$(eval $(call KernelPackage,usb2-oxnas))