aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/image/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-01-27 16:21:17 +0100
committerJo-Philipp Wich <jo@mein.io>2017-01-27 16:53:31 +0100
commit7f9d537f21f2bd79a8b5bfd86c50629c76b306dc (patch)
tree5f416f180e9fd39192d3ce9c92005b232cd06dd7 /target/linux/oxnas/image/Makefile
parentcf3d1b61bfc3f2dd6affe6e59019801d00f7f85f (diff)
downloadupstream-7f9d537f21f2bd79a8b5bfd86c50629c76b306dc.tar.gz
upstream-7f9d537f21f2bd79a8b5bfd86c50629c76b306dc.tar.bz2
upstream-7f9d537f21f2bd79a8b5bfd86c50629c76b306dc.zip
oxnas: put u-boot images into image staging directory
Do not put the u-boot images into the kernel build directory as this directory might get removed after kernel updates while the u-boot packages InstallDev recipe is not getting re-executed because it is still considered current, leading to image build failures later on due to missing images. To ensure that built bootloader images persist over kernel version updates in the buildroot, put them into the new STAGING_DIR_IMAGE directory. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target/linux/oxnas/image/Makefile')
-rw-r--r--target/linux/oxnas/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/oxnas/image/Makefile b/target/linux/oxnas/image/Makefile
index 7ad05844cc..bfa0f0cca7 100644
--- a/target/linux/oxnas/image/Makefile
+++ b/target/linux/oxnas/image/Makefile
@@ -15,7 +15,7 @@ DEVICE_VARS += DTS UBIFS_OPTS
KERNEL_LOADADDR := 0x60008000
define Build/ubootable
- (dd if="$(KDIR)/u-boot.bin" bs=128k conv=sync; \
+ (dd if="$(STAGING_DIR_IMAGE)/u-boot.bin" bs=128k conv=sync; \
dd if="$@" bs=128k conv=sync ) >> $@.new
@mv "$@.new" "$@"
endef