aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/orion/patches/200-dt2_board_support.patch
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-06-04 11:29:01 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-06-04 11:29:01 +0000
commita0e412a616d50b28b1f0eb305ef297af46b3fdf1 (patch)
tree15febcb69b877e799868ced3dd43875d0f0eaa09 /target/linux/orion/patches/200-dt2_board_support.patch
parent3a56df33ad00b2f20eb5cb0ceb8d4c1072dc97ad (diff)
downloadupstream-a0e412a616d50b28b1f0eb305ef297af46b3fdf1.tar.gz
upstream-a0e412a616d50b28b1f0eb305ef297af46b3fdf1.tar.bz2
upstream-a0e412a616d50b28b1f0eb305ef297af46b3fdf1.zip
versioned files and dirs still make no sense when you support only a single kernel...
SVN-Revision: 36836
Diffstat (limited to 'target/linux/orion/patches/200-dt2_board_support.patch')
-rw-r--r--target/linux/orion/patches/200-dt2_board_support.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/orion/patches/200-dt2_board_support.patch b/target/linux/orion/patches/200-dt2_board_support.patch
new file mode 100644
index 0000000000..91909abac0
--- /dev/null
+++ b/target/linux/orion/patches/200-dt2_board_support.patch
@@ -0,0 +1,26 @@
+--- a/arch/arm/mach-orion5x/Kconfig
++++ b/arch/arm/mach-orion5x/Kconfig
+@@ -16,6 +16,13 @@ config MACH_RD88F5182
+ Say 'Y' here if you want your kernel to support the
+ Marvell Orion-NAS (88F5182) RD2
+
++config MACH_DT2
++ bool "Freecom DataTank Gateway"
++ select I2C_BOARDINFO
++ help
++ Say 'Y' here if you want your kernel to support the
++ Freecom DataTank Gateway
++
+ config MACH_KUROBOX_PRO
+ bool "KuroBox Pro"
+ select I2C_BOARDINFO
+--- a/arch/arm/mach-orion5x/Makefile
++++ b/arch/arm/mach-orion5x/Makefile
+@@ -18,6 +18,7 @@ obj-$(CONFIG_MACH_BIGDISK) += d2net-setu
+ obj-$(CONFIG_MACH_NET2BIG) += net2big-setup.o
+ obj-$(CONFIG_MACH_MSS2) += mss2-setup.o
+ obj-$(CONFIG_MACH_WNR854T) += wnr854t-setup.o
++obj-$(CONFIG_MACH_DT2) += dt2-setup.o
+ obj-$(CONFIG_MACH_RD88F5181L_GE) += rd88f5181l-ge-setup.o
+ obj-$(CONFIG_MACH_RD88F5181L_FXO) += rd88f5181l-fxo-setup.o
+ obj-$(CONFIG_MACH_RD88F6183AP_GE) += rd88f6183ap-ge-setup.o