aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/orion/image/generic.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-01 14:42:03 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-04 11:41:53 +0100
commit1a63b819658d893f4454bbe75811a1f91cbfc07e (patch)
tree1e8a95eee05c1f6c4e54ba3769dc40f6f791a4ba /target/linux/orion/image/generic.mk
parent0917999396567a4763f4397284d55dfeb217bcc6 (diff)
downloadupstream-1a63b819658d893f4454bbe75811a1f91cbfc07e.tar.gz
upstream-1a63b819658d893f4454bbe75811a1f91cbfc07e.tar.bz2
upstream-1a63b819658d893f4454bbe75811a1f91cbfc07e.zip
orion: make image size errors non-fatal
Fixes build errors on the generic subtarget Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/orion/image/generic.mk')
-rw-r--r--target/linux/orion/image/generic.mk12
1 files changed, 4 insertions, 8 deletions
diff --git a/target/linux/orion/image/generic.mk b/target/linux/orion/image/generic.mk
index 18ea3991e9..22909ac73d 100644
--- a/target/linux/orion/image/generic.mk
+++ b/target/linux/orion/image/generic.mk
@@ -110,7 +110,7 @@ endef
define Image/Default/FileSizeCheck
# parameters: 1 = file path, 2 = maximum size in bytes
- [ `stat -c %s '$(1)'` -le $(2) ] || { echo ' ERROR: $(1) too big (> $(2) bytes)'; exit 1; }
+ [ `stat -c %s '$(1)'` -le $(2) ] || { echo ' ERROR: $(1) too big (> $(2) bytes)'; rm -f $(1); }
endef
@@ -215,18 +215,14 @@ define Image/Build/Linksys/wrt350nv2-builder
)
echo '#version 0x2020' >> '$(TMP_DIR)/$(2)_factory/$(2).par'
# create bin file for recovery and factory image
- ( \
+ -( \
cd '$(TMP_DIR)/$(2)_factory'; \
'$(STAGING_DIR_HOST)/bin/wrt350nv2-builder' -b '$(TMP_DIR)/$(2)_factory/$(2).par'; \
- )
- # copy bin file as recovery image
- $(CP) '$(TMP_DIR)/$(2)_factory/wrt350n.bin' '$(BIN_DIR)/openwrt-$(2)-$(1)-recovery.bin'
- # create factory image for stock firmware update mechanism
+ ) && $(CP) '$(TMP_DIR)/$(2)_factory/wrt350n.bin' '$(BIN_DIR)/openwrt-$(2)-$(1)-recovery.bin' && \
( \
cd '$(TMP_DIR)/$(2)_factory'; \
zip 'wrt350n.zip' 'wrt350n.bin'; \
- )
- '$(STAGING_DIR_HOST)/bin/wrt350nv2-builder' -z '$(TMP_DIR)/$(2)_factory/wrt350n.zip' '$(BIN_DIR)/openwrt-$(2)-$(1)-factory.img'
+ ) && '$(STAGING_DIR_HOST)/bin/wrt350nv2-builder' -z '$(TMP_DIR)/$(2)_factory/wrt350n.zip' '$(BIN_DIR)/openwrt-$(2)-$(1)-factory.img'
rm -rf '$(TMP_DIR)/$(2)_factory'
endef