aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/orion/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-06-04 13:51:17 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-06-04 13:51:17 +0000
commit7bb65fb9d7860faa4b9b1e07790fb5823a0249e2 (patch)
tree701aabf12d94bdeddafbf8d328dee2492eef9ad5 /target/linux/orion/Makefile
parent0244e57bb9fb9ebd1dd224bd5789ad9cc24b0175 (diff)
downloadupstream-7bb65fb9d7860faa4b9b1e07790fb5823a0249e2.tar.gz
upstream-7bb65fb9d7860faa4b9b1e07790fb5823a0249e2.tar.bz2
upstream-7bb65fb9d7860faa4b9b1e07790fb5823a0249e2.zip
add preliminary Marvell Orion support
SVN-Revision: 11352
Diffstat (limited to 'target/linux/orion/Makefile')
-rw-r--r--target/linux/orion/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/orion/Makefile b/target/linux/orion/Makefile
new file mode 100644
index 0000000000..4cc509ad28
--- /dev/null
+++ b/target/linux/orion/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=orion
+BOARDNAME:=Marvell Orion
+FEATURES:=squashfs
+
+LINUX_VERSION:=2.6.26-rc4
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="uImage"
+
+DEFAULT_PACKAGES += kmod-madwifi
+
+define Kernel/Configure
+ $(call Kernel/Configure/Default)
+ $(SED) 's,.*CONFIG_AEABI.*,$(if $(CONFIG_EABI_SUPPORT),CONFIG_AEABI=y,# CONFIG_AEABI is not set),' $(LINUX_DIR)/.config
+ $(if $(CONFIG_EABI_SUPPORT),echo '# CONFIG_OABI_COMPAT is not set' >> $(LINUX_DIR)/.config)
+endef
+
+$(eval $(call BuildTarget))