aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/openmoko/image/Makefile
diff options
context:
space:
mode:
authorMirko Vogt <mirko@openwrt.org>2008-12-12 00:02:36 +0000
committerMirko Vogt <mirko@openwrt.org>2008-12-12 00:02:36 +0000
commitb9dfb81f2aa45be745a8aed9684076210aed4152 (patch)
treeaceadd7f37096911a29c929988cbcf7c964a1c0b /target/linux/openmoko/image/Makefile
parent4571721ec22de116ad9998657e0a3c12da6405fb (diff)
downloadupstream-b9dfb81f2aa45be745a8aed9684076210aed4152.tar.gz
upstream-b9dfb81f2aa45be745a8aed9684076210aed4152.tar.bz2
upstream-b9dfb81f2aa45be745a8aed9684076210aed4152.zip
add support for target 3c24xx (more known as Openmoko GTA02 "Freerunner") and merge it with the openmoko-target and the work Michael Buesch <mb> did
SVN-Revision: 13609
Diffstat (limited to 'target/linux/openmoko/image/Makefile')
-rw-r--r--target/linux/openmoko/image/Makefile37
1 files changed, 0 insertions, 37 deletions
diff --git a/target/linux/openmoko/image/Makefile b/target/linux/openmoko/image/Makefile
deleted file mode 100644
index 34ca44b701..0000000000
--- a/target/linux/openmoko/image/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-#
-# Copyright (C) 2008 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-JFFS2_BLOCKSIZE := 128k
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-define Image/mkfs/jffs2/sub
- $(STAGING_DIR_HOST)/bin/mkfs.jffs2 --pad --little-endian --pagesize=0x800 --no-cleanmarkers -e $(patsubst %k,%KiB,$(1)) -o $(KDIR)/root.jffs2-$(1) -d $(TARGET_DIR)
- $(call add_jffs2_mark,$(KDIR)/root.jffs2-$(1))
- $(call Image/Build,jffs2-$(1))
-endef
-
-define Build/Clean
-endef
-
-define Build/Compile
-endef
-
-define Image/Prepare
- cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
-endef
-
-define Image/BuildKernel
- cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
-endef
-
-define Image/Build
- cp $(KDIR)/root.jffs2-128k $(BIN_DIR)/openwrt-$(BOARD)-rootfs
-endef
-
-$(eval $(call BuildImage))