aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/openmoko/image/Makefile
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2008-12-11 22:20:51 +0000
committerMichael Büsch <mb@bu3sch.de>2008-12-11 22:20:51 +0000
commit62769f04ab054796321b50acb8205054847a76e1 (patch)
tree7a9e67683112eac7e5239c50b9f9d0ae0f725d06 /target/linux/openmoko/image/Makefile
parentd91675a2b88ac9c8582afca7fcbd9f76d73391af (diff)
downloadupstream-62769f04ab054796321b50acb8205054847a76e1.tar.gz
upstream-62769f04ab054796321b50acb8205054847a76e1.tar.bz2
upstream-62769f04ab054796321b50acb8205054847a76e1.zip
Add basic framework for the openmoko platform.
The kernel does build and boot, but the rootfs build process is not completely implemented, yet. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13605 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/openmoko/image/Makefile')
-rw-r--r--target/linux/openmoko/image/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/openmoko/image/Makefile b/target/linux/openmoko/image/Makefile
new file mode 100644
index 0000000000..20f17590f3
--- /dev/null
+++ b/target/linux/openmoko/image/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Build/Clean
+endef
+
+define Build/Compile
+endef
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+endef
+
+define Image/BuildKernel
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+endef
+
+define Image/Build
+endef
+
+$(eval $(call BuildImage))