aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/openmoko/Makefile
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2008-12-11 22:20:51 +0000
committerMichael Büsch <mb@bu3sch.de>2008-12-11 22:20:51 +0000
commit62769f04ab054796321b50acb8205054847a76e1 (patch)
tree7a9e67683112eac7e5239c50b9f9d0ae0f725d06 /target/linux/openmoko/Makefile
parentd91675a2b88ac9c8582afca7fcbd9f76d73391af (diff)
downloadupstream-62769f04ab054796321b50acb8205054847a76e1.tar.gz
upstream-62769f04ab054796321b50acb8205054847a76e1.tar.bz2
upstream-62769f04ab054796321b50acb8205054847a76e1.zip
Add basic framework for the openmoko platform.
The kernel does build and boot, but the rootfs build process is not completely implemented, yet. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13605 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/openmoko/Makefile')
-rw-r--r--target/linux/openmoko/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/openmoko/Makefile b/target/linux/openmoko/Makefile
new file mode 100644
index 0000000000..22bfaea57f
--- /dev/null
+++ b/target/linux/openmoko/Makefile
@@ -0,0 +1,24 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=openmoko
+BOARDNAME:=Openmoko
+FEATURES:=squashfs usb
+
+LINUX_VERSION:=2.6.24.7
+
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="uImage"
+
+define Target/Description
+ Build fimware images for the Openmoko Smartphone.
+endef
+
+$(eval $(call BuildTarget))