aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-02-12 15:38:08 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-02-12 15:38:08 +0000
commitf8a6d9d74e24a1d5c936007542c0d61b6cab8bbb (patch)
tree9d384925eb28011bc67559e05ba23c96cb5afe2f /target/linux/omap
parent9a9b0be97b72c09c98f78858730706ee2777e27d (diff)
downloadupstream-f8a6d9d74e24a1d5c936007542c0d61b6cab8bbb.tar.gz
upstream-f8a6d9d74e24a1d5c936007542c0d61b6cab8bbb.tar.bz2
upstream-f8a6d9d74e24a1d5c936007542c0d61b6cab8bbb.zip
[omap]: handle some CONFIG_TARGET_ROOTFS_INCLUDE_ foo
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39578 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/omap')
-rw-r--r--target/linux/omap/image/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/target/linux/omap/image/Makefile b/target/linux/omap/image/Makefile
index e681b04267..1f6f28aded 100644
--- a/target/linux/omap/image/Makefile
+++ b/target/linux/omap/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2012-2013 OpenWrt.org
+# Copyright (C) 2012-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -22,6 +22,17 @@ define Image/BuildKernel
endef
define Image/Build
+
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
+ $(INSTALL_DIR) $(TARGET_DIR)/boot
+ $(CP) $(KDIR)/zImage $(TARGET_DIR)/boot/
+ endif
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
+ $(INSTALL_DIR) $(TARGET_DIR)/boot
+ $(CP) $(LINUX_DIR)/arch/arm/boot/dts/am335x*.dtb $(TARGET_DIR)/boot/
+ $(CP) $(LINUX_DIR)/arch/arm/boot/dts/omap3*.dtb $(TARGET_DIR)/boot/
+ $(CP) $(LINUX_DIR)/arch/arm/boot/dts/omap4*.dtb $(TARGET_DIR)/boot/
+ endif
$(call Image/Build/$(1),$(1))
endef