aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap4/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-01-14 23:02:56 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-01-14 23:02:56 +0000
commit8f76568da91dbe989e5365a4a6d3f50847b1c755 (patch)
treeafabe899aa387d9c1fd5509828b5ebe774a30bb7 /target/linux/omap4/image
parent26cb77ef885e1858d0f7f06efa765e0d5d5de749 (diff)
downloadupstream-8f76568da91dbe989e5365a4a6d3f50847b1c755.tar.gz
upstream-8f76568da91dbe989e5365a4a6d3f50847b1c755.tar.bz2
upstream-8f76568da91dbe989e5365a4a6d3f50847b1c755.zip
[target/omap4]: add support for OMAP4 based boards, starting with the PandaBoard
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29753 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/omap4/image')
-rw-r--r--target/linux/omap4/image/Makefile36
-rw-r--r--target/linux/omap4/image/boot.script3
2 files changed, 39 insertions, 0 deletions
diff --git a/target/linux/omap4/image/Makefile b/target/linux/omap4/image/Makefile
new file mode 100644
index 0000000000..5123c3a0a8
--- /dev/null
+++ b/target/linux/omap4/image/Makefile
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
+endef
+
+define Image/BuildKernel
+ mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n 'Boot Image' -d boot.script $(BIN_DIR)/boot.scr
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+endef
+
+define Image/Build
+ $(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-64k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=65536 conv=sync
+endef
+
+define Image/Build/jffs2-128k
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
+endef
+
+$(eval $(call BuildImage))
diff --git a/target/linux/omap4/image/boot.script b/target/linux/omap4/image/boot.script
new file mode 100644
index 0000000000..521f4389cf
--- /dev/null
+++ b/target/linux/omap4/image/boot.script
@@ -0,0 +1,3 @@
+fatload mmc 0:1 0x80000000 openwrt-omap4-uImage
+setenv bootargs vram=32M fixrtc mem=1G@0x80000000 root=/dev/mmcblk0p2 rootfstype=ext4 console=ttyO2,115200n8 rootwait
+bootm 0x80000000