aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap35xx
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
commite2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f (patch)
treef8563604e7685c30b0a2a675ca80379a34114565 /target/linux/omap35xx
parent040c06438896144dfe148910f922a0d9bb0058b0 (diff)
downloadupstream-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.gz
upstream-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.tar.bz2
upstream-e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f.zip
define a shared IMG_PREFIX variable used as a basename for image files, it contains board & subtarget infos (if appropriate) allowing subtargets to share the same bin directory without overwriting each other's files
SVN-Revision: 20834
Diffstat (limited to 'target/linux/omap35xx')
-rw-r--r--target/linux/omap35xx/image/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/target/linux/omap35xx/image/Makefile b/target/linux/omap35xx/image/Makefile
index 14b34174de..aa23c0c838 100644
--- a/target/linux/omap35xx/image/Makefile
+++ b/target/linux/omap35xx/image/Makefile
@@ -1,34 +1,32 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
JFFS2_BLOCKSIZE=128k
JFFS2OPTS += --little-endian --pagesize=0x800 --no-cleanmarkers --pad
-MAKE += -j5
define Image/BuildKernel
$(TARGET_CROSS)objcopy -O binary -R .note -R .comment -S $(LINUX_DIR)/arch/arm/boot/compressed/vmlinux linux.bin
mkimage -A arm -O linux -T kernel -C none -a 80008000 -e 80008000 -n "OpenWRT Kernel Image beagleboard" -d linux.bin uImage
mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n 'uImage.bin+mmc2' -d ../files/boot-mmc.cmd boot.scr
- mv uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
+ mv uImage $(BIN_DIR)/$(IMG_PREFIX)-$(KERNEL)-uImage
mv boot.scr $(BIN_DIR)/boot.scr
rm linux.bin
endef
define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-root.$(1))
+ $(call prepare_generic_squashfs,$(BIN_DIR)/$(IMG_PREFIX)-$(KERNEL)-root.$(1))
endef
define Image/Build
- $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-root.$(1)
- PADDING="true" PATH="$(TARGET_PATH)" ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(1).image 4 $(KDIR)/root.bootscript 240 $(KDIR)/root.$(1)
+ $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(KERNEL)-root.$(1)
+ PADDING="true" PATH="$(TARGET_PATH)" ./gen_image.sh $(BIN_DIR)/$(IMG_PREFIX)-$(1).image 4 $(KDIR)/root.bootscript 240 $(KDIR)/root.$(1)
$(call Image/Build/$(1),$(1))
endef