aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap35xx/image/Makefile
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2011-02-02 14:58:30 +0000
committerHamish Guthrie <hcg@openwrt.org>2011-02-02 14:58:30 +0000
commit40a4e53e18122a2003637d60afd293d007e1cecf (patch)
treee6af19e7892c83738c649be4b9b90625dea0665d /target/linux/omap35xx/image/Makefile
parent910f61bbdb2b5c4fe541b8720fdf268b891c72ea (diff)
downloadupstream-40a4e53e18122a2003637d60afd293d007e1cecf.tar.gz
upstream-40a4e53e18122a2003637d60afd293d007e1cecf.tar.bz2
upstream-40a4e53e18122a2003637d60afd293d007e1cecf.zip
[gumstix] Add support for ubifs
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25310 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/omap35xx/image/Makefile')
-rw-r--r--target/linux/omap35xx/image/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/omap35xx/image/Makefile b/target/linux/omap35xx/image/Makefile
index adaf395b70..e238c48af8 100644
--- a/target/linux/omap35xx/image/Makefile
+++ b/target/linux/omap35xx/image/Makefile
@@ -10,9 +10,12 @@ include $(INCLUDE_DIR)/image.mk
JFFS2_BLOCKSIZE=128k
JFFS2OPTS += --little-endian --pagesize=0x800 --no-cleanmarkers --pad
+UBIFS_OPTS = -m 2048 -e 126KiB -c 1996
+UBINIZE_OPTS = -m 2048 -p 128KiB -s 512
+
define Image/BuildKernel
$(TARGET_CROSS)objcopy -O binary -R .note -R .comment -S $(LINUX_DIR)/arch/arm/boot/compressed/vmlinux linux.bin
- mkimage -A arm -O linux -T kernel -C none -a 80008000 -e 80008000 -n "OpenWRT Kernel Image beagleboard" -d linux.bin uImage
+ mkimage -A arm -O linux -T kernel -C none -a 80008000 -e 80008000 -n "OpenWRT Kernel Image gumstix" -d linux.bin uImage
mkimage -A arm -O linux -T script -C none -a 0 -e 0 -n 'uImage.bin+mmc2' -d ../files/boot-mmc.cmd boot.scr
mv uImage $(BIN_DIR)/$(IMG_PREFIX)-$(KERNEL)-uImage
@@ -20,11 +23,13 @@ define Image/BuildKernel
rm linux.bin
endef
+ifndef CONFIG_TARGET_omap35xx_gumstix
define Image/Build
$(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(KERNEL)-root.$(1)
PADDING="true" PATH="$(TARGET_PATH)" ./gen_image.sh $(BIN_DIR)/$(IMG_PREFIX)-$(1).image 4 $(KDIR)/root.bootscript 240 $(KDIR)/root.$(1)
$(call Image/Build/$(1),$(1))
endef
+endif
ifdef CONFIG_TARGET_omap35xx_gumstix
define Image/Prepare