aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap35xx/Makefile
diff options
context:
space:
mode:
authorJens Muecke <jens@nons.de>2009-12-14 20:58:18 +0000
committerJens Muecke <jens@nons.de>2009-12-14 20:58:18 +0000
commit842f6f01deb677dbb1f1351a983ee001662c18e6 (patch)
tree637bd0615c7662ab5948e30133ba2bc6aafd3b11 /target/linux/omap35xx/Makefile
parent845dd1e62b321c679dd56a08fae32ce0fbe29b5b (diff)
downloadupstream-842f6f01deb677dbb1f1351a983ee001662c18e6.tar.gz
upstream-842f6f01deb677dbb1f1351a983ee001662c18e6.tar.bz2
upstream-842f6f01deb677dbb1f1351a983ee001662c18e6.zip
Make beagleboard as subtarget from omap35xx
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18779 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/omap35xx/Makefile')
-rw-r--r--target/linux/omap35xx/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/omap35xx/Makefile b/target/linux/omap35xx/Makefile
new file mode 100644
index 0000000000..2487887767
--- /dev/null
+++ b/target/linux/omap35xx/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2006-2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=omap35xx
+BOARDNAME:=TI OMAP35xx
+FEATURES:=broken
+SUBTARGETS=generic
+
+LINUX_VERSION:=2.6.32-rc5
+KERNELNAME:="uImage"
+
+DEVICE_TYPE=developerboard
+
+define Target/Description
+ omap35xx arm
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))