aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx/patches-2.6.35
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-08-09 18:43:43 +0000
committerMichael Büsch <mb@bu3sch.de>2010-08-09 18:43:43 +0000
commit8b934b8d898b482bc52ab6f9d1081b9a7c750d11 (patch)
tree2105aa25fd31cfb1e57a6424b18a1ca67f743919 /target/linux/omap24xx/patches-2.6.35
parent27a297eecedf6ab62ee7c7f8b60327ae2d2898bf (diff)
downloadupstream-8b934b8d898b482bc52ab6f9d1081b9a7c750d11.tar.gz
upstream-8b934b8d898b482bc52ab6f9d1081b9a7c750d11.tar.bz2
upstream-8b934b8d898b482bc52ab6f9d1081b9a7c750d11.zip
omap24xx: Update kernel config. This also fixes module loading.
SVN-Revision: 22564
Diffstat (limited to 'target/linux/omap24xx/patches-2.6.35')
-rw-r--r--target/linux/omap24xx/patches-2.6.35/500-cbus.patch7
1 files changed, 4 insertions, 3 deletions
diff --git a/target/linux/omap24xx/patches-2.6.35/500-cbus.patch b/target/linux/omap24xx/patches-2.6.35/500-cbus.patch
index 04ab3d2a83..e490974ea0 100644
--- a/target/linux/omap24xx/patches-2.6.35/500-cbus.patch
+++ b/target/linux/omap24xx/patches-2.6.35/500-cbus.patch
@@ -5,7 +5,7 @@
drivers/cbus/Makefile | 14
drivers/cbus/cbus.c | 309 ++++++++++++++++
drivers/cbus/cbus.h | 36 +
- drivers/cbus/retu-headset.c | 355 ++++++++++++++++++
+ drivers/cbus/retu-headset.c | 356 ++++++++++++++++++
drivers/cbus/retu-pwrbutton.c | 118 ++++++
drivers/cbus/retu-rtc.c | 477 +++++++++++++++++++++++++
drivers/cbus/retu-user.c | 425 ++++++++++++++++++++++
@@ -17,7 +17,7 @@
drivers/cbus/tahvo.c | 443 +++++++++++++++++++++++
drivers/cbus/tahvo.h | 61 +++
drivers/cbus/user_retu_tahvo.h | 75 +++
- 18 files changed, 4524 insertions(+), 1 deletion(-)
+ 18 files changed, 4525 insertions(+), 1 deletion(-)
--- /dev/null
+++ linux-2.6.35/drivers/cbus/cbus.c
@@ -1032,7 +1032,7 @@
+#endif /* __DRIVERS_CBUS_RETU_H */
--- /dev/null
+++ linux-2.6.35/drivers/cbus/retu-headset.c
-@@ -0,0 +1,355 @@
+@@ -0,0 +1,356 @@
+/**
+ * Retu/Vilma headset detection
+ *
@@ -1060,6 +1060,7 @@
+#include <linux/delay.h>
+#include <linux/input.h>
+#include <linux/platform_device.h>
++#include <linux/slab.h>
+
+#include "retu.h"
+