aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx/image
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-03-25 15:20:59 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-03 21:27:12 +0200
commitcd3b29853380676bb7e51283050c2044048f8f85 (patch)
tree254984a7195994f26fa3fd6b9c3a7c9b9182bf1e /target/linux/omap24xx/image
parent8ba38cc1458bf0601704bcfd2b69939a7bd4cf06 (diff)
downloadupstream-cd3b29853380676bb7e51283050c2044048f8f85.tar.gz
upstream-cd3b29853380676bb7e51283050c2044048f8f85.tar.bz2
upstream-cd3b29853380676bb7e51283050c2044048f8f85.zip
omap24xx: Remove unmaintained target
This target only supports kernel 4.1, which is not supported in OpenWrt any more for multiple releases. It also looks like there is no active maintainer for this target. Remove the code and all the packages which are only used by this target. To add this target to OpenWrt again port it to a recent and supported kernel version. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target/linux/omap24xx/image')
-rw-r--r--target/linux/omap24xx/image/Makefile27
1 files changed, 0 insertions, 27 deletions
diff --git a/target/linux/omap24xx/image/Makefile b/target/linux/omap24xx/image/Makefile
deleted file mode 100644
index 316cce0f9f..0000000000
--- a/target/linux/omap24xx/image/Makefile
+++ /dev/null
@@ -1,27 +0,0 @@
-#
-# Copyright (C) 2010-2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-NAND_BLOCKSIZE=2048-128k
-
-define Image/BuildKernel
- cat $(KDIR)/zImage $(DTS_DIR)/omap2420-n810.dtb > $(BIN_DIR)/$(IMG_PREFIX)-zImage
- chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-zImage
-endef
-
-define Image/Build/squashfs
- $(call prepare_generic_squashfs,$(BIN_DIR)/$(IMG_PREFIX)-root.$(1))
-endef
-
-define Image/Build
- $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-root.$(1)
- $(call Image/Build/$(1),$(1))
-endef
-
-
-$(eval $(call BuildImage))