aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx/image
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-08-08 14:16:48 +0000
committerMichael Büsch <mb@bu3sch.de>2010-08-08 14:16:48 +0000
commita4c446a2bc4024ddef2a259d97dae5b0671c1fea (patch)
treea40a40e5bfc0cbdf6bb708cbcdc68851de49c951 /target/linux/omap24xx/image
parent3a4b11a5ef3a4dc781bdf24788801c6d281f2378 (diff)
downloadupstream-a4c446a2bc4024ddef2a259d97dae5b0671c1fea.tar.gz
upstream-a4c446a2bc4024ddef2a259d97dae5b0671c1fea.tar.bz2
upstream-a4c446a2bc4024ddef2a259d97dae5b0671c1fea.zip
Add omap24xx.
Boots the kernel with working video and serial console. Userland is untested. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22530 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/omap24xx/image')
-rw-r--r--target/linux/omap24xx/image/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/omap24xx/image/Makefile b/target/linux/omap24xx/image/Makefile
new file mode 100644
index 0000000000..682109a249
--- /dev/null
+++ b/target/linux/omap24xx/image/Makefile
@@ -0,0 +1,29 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+JFFS2_BLOCKSIZE=128k
+JFFS2OPTS += --little-endian --pagesize=0x800 --no-cleanmarkers --pad
+
+
+define Image/BuildKernel
+ $(CP) $(LINUX_DIR)/arch/arm/boot/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+ chmod 0644 $(BIN_DIR)/$(IMG_PREFIX)-zImage
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(BIN_DIR)/$(IMG_PREFIX)-root.$(1))
+endef
+
+define Image/Build
+ $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-root.$(1)
+ $(call Image/Build/$(1),$(1))
+endef
+
+
+$(eval $(call BuildImage))