aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap/profiles
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-04-15 19:00:10 +0200
committerAlexander Couzens <lynxis@fe80.eu>2017-04-24 18:03:31 +0200
commit9b8e274e1b10a0d7a3066b5b1a62e24f7b313d9b (patch)
tree3a0f2014fdb43966d3285c3f31dfa4af3deed2c5 /target/linux/omap/profiles
parent23fc55e7235c719856ea4ba23a3dabb804d2fed9 (diff)
downloadupstream-9b8e274e1b10a0d7a3066b5b1a62e24f7b313d9b.tar.gz
upstream-9b8e274e1b10a0d7a3066b5b1a62e24f7b313d9b.tar.bz2
upstream-9b8e274e1b10a0d7a3066b5b1a62e24f7b313d9b.zip
omap: rework image generation and profiles
Migrate to new image generation and introduce sdcard generation (based on sunxi). Profile now generated via image/Makefile instead of profiles/ directory. Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
Diffstat (limited to 'target/linux/omap/profiles')
-rw-r--r--target/linux/omap/profiles/00-default.mk9
-rw-r--r--target/linux/omap/profiles/beagleboard.mk23
2 files changed, 8 insertions, 24 deletions
diff --git a/target/linux/omap/profiles/00-default.mk b/target/linux/omap/profiles/00-default.mk
index 3ff040d2e4..c0af55719b 100644
--- a/target/linux/omap/profiles/00-default.mk
+++ b/target/linux/omap/profiles/00-default.mk
@@ -6,7 +6,14 @@
#
define Profile/Default
- NAME:=Default Profile
+ NAME:=Default Profile
+ PACKAGES:= \
+ kmod-usb-net \
+ kmod-usb-net-asix kmod-usb-net-asix-ax88179 kmod-usb-net-hso \
+ kmod-usb-net-kaweth kmod-usb-net-pegasus kmod-usb-net-mcs7830 \
+ kmod-usb-net-smsc95xx kmod-usb-net-dm9601-ether \
+ wpad-mini
+ PRIORITY := 1
endef
define Profile/Default/Description
diff --git a/target/linux/omap/profiles/beagleboard.mk b/target/linux/omap/profiles/beagleboard.mk
deleted file mode 100644
index aa8b68a43e..0000000000
--- a/target/linux/omap/profiles/beagleboard.mk
+++ /dev/null
@@ -1,23 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/BEAGLEBOARD
- NAME:=EBV BeagleBoard
- DEFAULT_PACKAGES += \
- kmod-usb-net kmod-usb-net-asix \
- kmod-usb-net-asix-ax88179 kmod-usb-net-hso \
- kmod-usb-net-kaweth kmod-usb-net-pegasus \
- kmod-usb-net-mcs7830 kmod-usb-net-smsc95xx \
- kmod-usb-net-dm9601-ether
-endef
-
-define Profile/BEAGLEBOARD/Description
- Package set for the BEAGLEBOARD and similar devices.
- Contains various USB-NET drivers for boards without Ethernet.
-endef
-
-$(eval $(call Profile,BEAGLEBOARD))